The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
Loco translation no...
 
Share:
Notifications
Clear all

Loco translation not working

8 Posts
3 Users
0 Reactions
3,224 Views
Posts: 21
Topic starter
(@assafmanor)
Eminent Member
Joined: 2 years ago

I'm using the loco translation plugin. It works fine in translating all of my plugins (into Hebrew). I have no idea why - but it completely doesn't work for wpDiscuz although the Hebrew translation file exists. I have searched google and also the forums here for loco translation issues but haven't found anything. I would appreciate greatly any assistance in the matter.

7 Replies
Tom
Posts: 494
 Tom
Support
(@tomson)
Honorable Member
Joined: 9 years ago

@assafmanor,

  1. Are you sure the issue is not a cache issue? Please delete all caches and provide with an exact example of the phrase that you're translating.
  2. Leave a link to the website blog post where we can see the issue. P
  3. Provide some screenshots showing the translation file you use in Loco plugin.
  4. Let me know where is the translation file saved. Have you copied it to /wp-content/languages/plugins/ folder?
  5. What is the default language of your WordPress in Settings > General admin page?
  6. What is the wpDiscuz form language in wpDiscuz > Forms > Edit Default Form screen? I mean this one: https://wpdiscuz.com/docs/wpdiscuz-7/translation/translation-methods/#comment-form-translation

 

Reply
Posts: 21
Topic starter
(@assafmanor)
Eminent Member
Joined: 2 years ago

Hi Tom,

 

Thank for your rapid reply.

 

1. Yes, the pages are not cached, so it's not a caching issue. Also, it's not this or that phrase. Nothing is translated.

2. I cannot leave a link for it's a closed part of my site for registered users.

3. I've attached a screen-shot.

4. I don't understand. Why do I need to copy anything? Usually with loco - it just works.

5. The default language of my WordPress site is Hebrew.

6. The wpDiscuz form language is "he_IL" as it should.

 

Thank you.

image
Reply
1 Reply
Tom
 Tom
Support
(@tomson)
Joined: 9 years ago

Honorable Member
Posts: 494

@assafmanor,

Thank you for the info, please note if you don't copy the translation file using the built-in Loco Copy function all your new translated words will be lost after the update.

The correct place to keep translation files is languages/plugins/wpdiscuz-{locale}.po

If you don't do any customization, or you don't add a new translation phrase, you can keep it as is.

 

You have not provided any link to the page where we can see no translated words. Also, you've not provided information what exactly is not translated. Some phrases shouls be translated directly in the wpDiscuz > Forms > Edit form fields. So you should edit words and change them to Hebrew. Have you read this doc? https://wpdiscuz.com/docs/wpdiscuz-7/translation/translation-methods/#comment-form-translation

Reply
Posts: 21
Topic starter
(@assafmanor)
Eminent Member
Joined: 2 years ago

I placed them in the directory you've mentioned - still nothing. Also, I really don't understand why is anything special needed to be done. With any other plugin loco just automatically translated it.

I did not provide what exactly is not translated, for as I wrote - nothing is translated.

 

Yes I saw that some field can be translated via the edit form fields, but believe Loco should have translated them too - no?

Reply
3 Replies
Tom
 Tom
Support
(@tomson)
Joined: 9 years ago

Honorable Member
Posts: 494

@assafmanor,

1. I've already mentioned that nothing specific should be done, it should only be done if you've edited the translation file, if it’s not edited you should not do that.

2. it's not specific, it's a general rule, all language customization will be lost if you edit the translation file in the plugin directory, because the plugin is fully deleted and replaced with new version after the update

3. Again, what phrases are not translated? Please show screenshots and eave a direct URL to that page.

 

Reply
(@assafmanor)
Joined: 2 years ago

Eminent Member
Posts: 21

@tomson Hello Tom,

I did as you instructed but the translation is not showing up. Here is a link for a post so you could see for yourself. Just nothing is translated to Hebrew.

Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

Hi @assafmanor 

Please confirm that the "Use Plugin .PO/.MO Files" option is enabled. The option is located in the Dashboard > wpDiscuz > Settings > General Settings tab. 

Reply
Share: