Multi language tran...
 
Share:
Notifications
Clear all

Issue [Solved] Multi language translation

8 Posts
2 Users
0 Likes
296 Views
Posts: 6
Topic starter
(@lapinbleu007)
Active Member
Joined: 5 months ago

Hi guys, I followed your instructions on how to set up your wpdiscuz plugin for sites with multiple languages but it is not working for me. https://wpdiscuz.com/docs/wpdiscuz-7/getting-started/manage-comment-forms/comment-form-settings/#language

First, I duplicated the default form called "Default Form" and I renamed them so I have two forms. I then changed the language flag as well as the text in the French form but somehow the English or default form is still being used.

I am using PolyLang in order to change the language and it works perfectly for other things. It changes the default language used on my website without any problems.

I do notice that my webpage has either "fr-FR" or "en-EN" when the language changes. From what I've read, that is the standard not "fr_FR" or "en_EN". Sadly, matching the form language code to what my page has doesn't work either. 

What do you think? I wasn't able to find anything about this problem on your community forum. Thanks in advance.

PolyLang (Version 3.4.6)
wpDiscuz (Version 7.6.10)
Wordpress (Version 6.3.1)

image

 

image
image
Topic Tags
7 Replies
Posts: 65
Support
(@zackar)
Trusted Member
Joined: 8 years ago

Hi @lapinbleu007

We tested PolyLang and wpDiscuz together and everything works fine. You can see everything at the link https://app.screencast.com/7cNaF9hzn2ZWr

1 Reply
(@lapinbleu007)
Joined: 5 months ago

Active Member
Posts: 6

@zackar Hi, thanks so much for your video. I verified my settings again and I still can't get things to work. I thought that it was just a problem because I declared the wpDiscuz blocks in my template pages that are included on my pages and posts but I still have the same result. 

In order to test this in a more neutral setting, I created two dummy pages pages that contain the wpDiscuz blocks. One page is in French and the other is in English just like how you have it. Each page have the control and nothing else. 

I made sure to have different text in the wpDiscuz forms just like how you have thing. The language code is also just like how you have it. 

What are your PolyLang settings? I believe I changed my settings from the original settings to make things work for me a few months ago. Here is a screen print of the PolyLang settings on my side. Thanks again.

image
Posts: 65
Support
(@zackar)
Trusted Member
Joined: 8 years ago

@lapinbleu007

My PolyLang settings:

image

 

 

1 Reply
(@lapinbleu007)
Joined: 5 months ago

Active Member
Posts: 6

@zackar Hi again and thanks for your screen print. I still have the same issue. I briefly changed my settings to match your but the problem is still with me. I am going to continue to look for a fix. Perhaps I'll try this on my local machine like you do see things better. Ciao

Posts: 6
Topic starter
(@lapinbleu007)
Active Member
Joined: 5 months ago

Hi, I still can't get figure out my problem. I was able to spin up a docker image with wordpress and I added the Polylang plugin as well as my Spectra pro theme and Spectra plugin because those are my main plugins. I then added the WpDiscuz plugin and set up the us and French forms. I then added pages to host the page control with one in English and the other one in French and bingo, everything worked. I just can't get this to work on my real wordpress website. I even deactivated most of my plugins with no luck. 

I should note that I am using a paid version of the Polylang plugin and it has extra options that I am using. These extra options are not available on the docker installation.

It just seems that there is something that stops the French form from being loaded despite me using the code fr_FR as per your documentation. I have check and rechecked your documents and I can't find anything that I am doing wrong. 

I am currently using the following plugin versions :
Wordpress 6.3.2
wpDiscuz 7.6.10

Thanks in advance

Posts: 65
Support
(@zackar)
Trusted Member
Joined: 8 years ago

Hi @lapinbleu007

Can you create a staging site (clone) of your real site and send the admin logins and password to info[at]gvectors.com so that we can test it?

1 Reply
(@lapinbleu007)
Joined: 5 months ago

Active Member
Posts: 6

@zackar Hi, I appreciate your help but I'll be moving to something else. Take care.

Share: