wpDiscuz - WordPress Comment Plugin
Uploading file type...
Clear all

[Closed] Uploading file type error

Posts: 3
Topic starter
New Member
Joined: 1 year ago

Since the update to 7.0.3, the Media Uploader addon does not allow any user to upload a file with the m4a extension. Upon attempting to do so, I get the default "Not allowed file type" message.

I tried putting the following code in the current active theme functions.php file, but it still doensn't work

add_filter("upload_mimes", function ($t, $u) {
if (empty($t["m4a"])) {
$t["m4a"] = "audio/x-m4a";
return $t;
}, 10, 2);
1 Reply
Posts: 4092
Support member
Joined: 4 years ago

Hi @drwoenl,

Please navigate to Dashboard > wpDiscuz > Settings > Comment Content and Media admin page find the "Allowed File Types" section and make sure the "m4a" checkbox is enabled.

For further support, please open a new support topic in gVectors.com forum. This topic will be closed soon. 

Please note all questions related to paid addons should be asked in the gVectors.com forum. Here we only support issues related to free wpDiscuz plugin.