wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] WP Discus and Divi Theme Builder  


Frkmaidk
Posts: 18
(@frkmaidk)
Active Member
Joined: 3 months ago

Hi there

I've been very happy with your plug-in, but unfortunatly it doesn't work probably with Divi Theme Builder.
People are able to comment, but the awesome green buble, that people can click to flyyyyy down to the comment-section is missing 🙁

I can see the buble when I'm in editing mode for a post, but not when I visit the website to look at the post ...

I had Divi Support look into it, and the plug-in works fine with the regular Divi, but not when you use the theme builder (which is essential for me).
Are you aware of this? or is it something you can look into? I know more and more people are using the theme builder as a part of DIVI.

Kind regards

31 Replies
Asti
Posts: 1611
 Asti
Support
(@asti)
Support member
Joined: 3 years ago

@frkmaidk,

Please leave some example URL to allow us to check the issue. 

13 Replies
Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti Sure thing 🙂 for example https://frkmai.dk/frontline-hero/ - but it is on all posts, that it doesn't work anymore ...

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

Have you disabled the Comment Bubble? We don't see it on the page, you've provided us. 

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@astiNo, that is the whole issue. It's not visible when you use Divi Theme Builder.

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

Could you please send the admin login details to info[at]gvectors.com email address? I'll ask the developers to check the issue for you. 

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti info@gvectors.com right? just want to be sure before I send my password 😀

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

yes @frkmaidk,

that is the correct email address. 

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti Thank you for your help 🙂 Have a great day ...

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

We'll check and back to you asap. 

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

This is a plugin conflict for sure. One of the active plugins doesn't allow the comment bubble to be displayed. Please deactivate the plugins one by one and check after each deactivation to find a problem maker. 

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti Hi again ...

I tried to deactivate every single plugin, except WpDiscuz, and it is still not working.
I believe Divi was right when they said it's something that clashes with their software, when you use the "theme builder" ...

Your plugin works perfectly when you don't use the theme builder.

But more and more people use the theme builder in DIVI, so perhaps you would look into how to work around it?

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

We've checked this on our test websites. We've installed the Divi and the wpDiscuz plugins and the bubble shows up.

Please install and activate the Duplicator — WordPress Migration Plugin, backup your WordPress site, and send it to info[at]gvectors.com email address to allow us to check it.

You can also create a dev/staging copy of your website in some sub-domain and send admin details to us. You can use the same Duplicator plugin to create that site.

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti
Have you also tried on sites made with the theme-builder activated, before I do all that ??

It's not enough to just try Divi + WpDiscuz ... you need to activate the theme builder too on the specific site that you are checking for the green bubble.

Even Divi tried everything on my site ... and they say it IS the theme builder that's causing problems with your plug-in.

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

The developers tried n the same way as you mentioned. 

Frkmaidk
Posts: 18
(@frkmaidk)
Active Member
Joined: 3 months ago

I just deactivated the theme builder on one specific post, when I do that, it's working again.
Please see the 3 videoes in sequence.

It's really not a problem with a random plugin, it is the theme builder. As I said, I already tried to deactivate all other plug-ins on beforehand.

All I wanted to know, was if you were aware of this clash with the Divi theme builder ... and if you would try to fix it...

1 Reply
Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18
Frkmaidk
Posts: 18
(@frkmaidk)
Active Member
Joined: 3 months ago

Video 3

Frkmaidk
Posts: 18
(@frkmaidk)
Active Member
Joined: 3 months ago

Hi there Asti.

Never heard from you again.

The "bubble" still does not work when you use the Divi Theme Builder.

I have an example here:

This post does not have the theme builder enabled: https://frkmai.dk/haekleopskrifter/

This post does: https://frkmai.dk/grydelap-med-blomst/

The bubble only works on posts where the theme builder isn't used.

Have you found a way to fix it?

11 Replies
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

Please let us know have you used the Divi shortcode for displaying comments? 

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti

Hi Asti

Which shortcode is that? 🙂

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

Which shortcode is that?

Here it is: 

https://elegantenthusiast.com/divi-comment-module-shortcode/

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

And where should I put that?
I already have the comment section on every post.
It's just the green bubble in the left side that is missing when the theme builder is enabled ...

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

You shouldn't put that. Please read attentively the post. I've asked you if you've used it or not?

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti Nope, no shortcode used - didn't know it excisted 🙂

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

Please send the admin login details to info[at]gvectors.com email address. 

Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti just sent it 🙂

 

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

We've got the following message:

2020 10 15 16 34 55
Frkmaidk
(@frkmaidk)
Joined: 3 months ago

Active Member
Posts: 18

@asti just sent you a new password - same username.
I works here ...

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

@frkmaidk,

Please read the description of the issue below. 

In the 1012 line of the framework.php of the Divi builder, there is code that closed the comments for the current post. 

The file is located in the wp-content/themes/Divi/includes/builder/ folder. Please comment out that line and check again. 

Then either keep the line commented out or contact the Divi support and ask them to change the code. 

Frkmaidk
Posts: 18
(@frkmaidk)
Active Member
Joined: 3 months ago

Hi there Asti 🙂

It worked. I wrote to Divi support and they fixed it for me.
I'm attaching af screenshot of what they did, just if anyone else has the same problem in the future 🙂

Thank you for your help and patience 🙂

Screen Shot 2020 10 16 at 11.42.57 AM
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1611

Thank you for letting us know. Glad to hear that the issue is solved.

Share: