wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Query about e-mail notification/confirmation from wpDiscuz.  

Page 1 / 2

Bale
Posts: 22
 Bale
(@bale)
Eminent Member
Joined: 3 months ago

Dear wpDiscuz Team,

I have questions as follows:

  1. How to change the email address that is used for email notification/confirmation to the guest? Currently, the email is the same as the one I use for WordPress login, but I want to use a different email address for the notification/confirmation. I don’t want the guest to know my WordPress login email.
  2. When a guest subscribes, there is an email with a link confirmation sent to the guest email. There is a warning from Gmail that “Suspicious link. This link leads to an untrusted site. Are you sure you want to proceed to mydomain.com?” Please note that mydomain.com is https with SSL certificate. How to prevent the warning, as this alarm may avoid the guest to proceed with the subscription.

Note: my wpDiscuz version is 7.0.7 and my Wordpress version is 5.5

Thank you

10 Replies
Asti
Posts: 1669
 Asti
Support
(@asti)
Support member
Joined: 3 years ago
Posted by: @bale

How to change the email address that is used for email notification/confirmation to the guest? Currently, the email is the same as the one I use for WordPress login, but I want to use a different email address for the notification/confirmation. I don’t want the guest to know my WordPress login email.

Please read this support topic: https://wpdiscuz.com/community/postid/1073/

When a guest subscribes, there is an email with a link confirmation sent to the guest email. There is a warning from Gmail that “Suspicious link. This link leads to an untrusted site. Are you sure you want to proceed to mydomain.com?” Please note that mydomain.com is https with SSL certificate. How to prevent the warning, as this alarm may avoid the guest to proceed with the subscription.

The issue doesn't have any relation to the wpDiscuz plugin. I've found the following articles. Those may be helpful for you:

Bale
Posts: 22
 Bale
(@bale)
Eminent Member
Joined: 3 months ago

Dear wpDiscuz,

  1. Thank you for your prompt reply. However, your response is not what I am asking for. I have followed your steps, but my WordPress login email is still revealed.  My concern is that I don't want the Guest to know my WordPress login email. How to change or hide it from the notification/confirmation email? Please refer to the screenshot attached for your easy reference.
notification confirmation email
  1. Noted on your reply that this issue is not related with wpDiscuz plugin. Although the article is not solving my problem because my domain is already https with SSL certificate, but I appreciate your help.
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1669

@bale,

Thank you for your prompt reply. However, your response is not what I am asking for. I have followed your steps, but my WordPress login email is still revealed.  My concern is that I don't want the Guest to know my WordPress login email. How to change or hide it from the notification/confirmation email? Please refer to the screenshot attached for your easy reference.

In the case of the wpDiscuz plugin, it always uses the no-reply@yourdomain.com email address. There is some other plugin that changes the email address and uses the admin email address, instead of it. 

Bale
Posts: 22
 Bale
(@bale)
Eminent Member
Joined: 3 months ago

Dear wpDiscuz,

I cannot find the plugin that can change the email address instead of using admin email address that you have mentioned above.

Although I cannot find a way to change it, I find a way to hide it.  

I have deactivated all the plugin to find the root cause and found the culprit. Apparently, I installed a plugin which could enforce WordPress to always include my admin email address (WordPress login) in all notifications that are sent out from my site. Once I deactivate this plugin, then the Guest only can see no-reply@blogname.com without my admin email address. This should solve the issue.

Another question, when a Guest register to my site, whether via Facebook or Instagram, is it possible for the Guest who posts a comment to include his/her own Facebook/Instagram Avatar, instead of using the site default Avatar?

1 Reply
Bale
 Bale
(@bale)
Joined: 3 months ago

Eminent Member
Posts: 22
Posted by: @bale

Another question, when a Guest register to my site, whether via Facebook or Instagram, is it possible for the Guest who posts a comment to include his/her own Facebook/Instagram Avatar, instead of using the site default Avatar?

Just want to share, it seems that I found the solution by myself.

Settings – General Settings – Purge All Avatar Caches

Settings – Comment Thread Features:

Default Avatar Source URL for Users: (must be blank!)

Default Avatar Source URL for Guests: (can be blank)

Enable Sitewide Usage of Default Avatars: (switch off!)

 

Previously I switched on the sitewide usage of default avatars and I also specified the default avatar for Users, but this setting prevented the Users to display their own Social Media Avatar in the wpDiscuz.

Bale
Posts: 22
 Bale
(@bale)
Eminent Member
Joined: 3 months ago

Suddenly all the avatars disappeared again. I totally cannot understand.

Bale
Posts: 22
 Bale
(@bale)
Eminent Member
Joined: 3 months ago

Sorry, after I Purge All Avatar Caches, then all avatars reappear again. 😓 

Bale
Posts: 22
 Bale
(@bale)
Eminent Member
Joined: 3 months ago

Dear wpDiscuz,

There is a typo error in the subscription confirmation email.

It should be 'Subscription', not 'Subscrption'. Kindly fix this, thank you.

Subscrption
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1669

@bale,

You can edit it yourself. The email templates can be found and managed in the Dashboard > wpDiscuz > Phrases > Email admin page. 

Page 1 / 2
Share: