wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] My wordpress login username is showing up next to my name in comments


ksands
Posts: 6
Topic starter
(@ksands)
Active Member
Joined: 2 months ago

I just noticed that next to my name in comments, it shows "@[my wordpress username]." I don't know what this is or why, and can't figure out how to get rid of it. But I do not want it there. Can somebody help me? Thanks.

15 Replies
Kym
Posts: 2
 Kym
(@kym)
New Member
Joined: 2 months ago

I run a website and all of my logged in users are now showing their user name since I did the update this morning.

8 Replies
ksands
(@ksands)
Joined: 2 months ago

Active Member
Posts: 6

@kym I only noticed it this morning (after the update) as well. I wonder if there's a way to reverse that update. For privacy purposes, I sure don't want my Wordpress username showing up for all the world to see.

psina2
(@psina2)
Joined: 2 months ago

New Member
Posts: 4

@ksands wp-content\plugins\wpdiscuz\utils\class.WpdiscuzHelper.php

edit line 410

ksands
(@ksands)
Joined: 2 months ago

Active Member
Posts: 6

@psina2 Thank you. But I'm sorry, I do not know how to get into that section to make that change.

ksands
(@ksands)
Joined: 2 months ago

Active Member
Posts: 6

I don't want it to show anything there. I don't have a twitter account, and I especially don't want it to show my Wordpress username.

psina2
(@psina2)
Joined: 2 months ago

New Member
Posts: 4

@ksands add custom css code:

span.wpd-user-nicename{ display: none;}
psina2
(@psina2)
Joined: 2 months ago

New Member
Posts: 4
div#wpdcom span.wpducm-user-nicename {
   display: none !important;
}
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 4116

@psina2,

Just disable the User Mentioning option. More info here: More info here: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/subscription-and-user-following/#enable-user-mentioning  

There is not necessary to use the CSS code. 

ksands
(@ksands)
Joined: 2 months ago

Active Member
Posts: 6

@asti That worked! Thank you so much.

 

mdw
Posts: 2
 mdw
(@mdw)
New Member
Joined: 2 months ago

I'm also seeing this with the latest update. I definitely do not want it showing random visitors our usernames. I went looking for an option to turn it off and as far as I can tell there isn't one. I'm surprised given the sheer number of options wpdiscuz has that the authors didn't add an option to turn off this new feature.

1 Reply
mdw
 mdw
(@mdw)
Joined: 2 months ago

New Member
Posts: 2

I found another forum post on the topic, but the instructions didn't work for me:
https://wpdiscuz.com/community/troubleshooting/how-to-disable-nicenames/#post-1830

Kym
Posts: 2
 Kym
(@kym)
New Member
Joined: 2 months ago

I've tried both CSS options with no success. 

3 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 4116

Dear users!

This is a WordPress user nicename. This is for the user mentioning feature. The logic is the same as in WordPress. You can see the same for example on the WordPress support forum: https://wordpress.org/plugins/wpdiscuz/

If you want to hide it just disable the User Mentioning option. More info here: More info here: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/subscription-and-user-following/#enable-user-mentioning

Gabriel_
(@gabriel_)
Joined: 2 months ago

New Member
Posts: 1

@kym I had the same problem after the update.

This is what did the trick for me: Under Wpdiscuz > Subscription and User Following > Enable User Mentioning - Toggle Off.

 

Screen Shot 2021 11 22 at 14.13.46
ksands
(@ksands)
Joined: 2 months ago

Active Member
Posts: 6

@gabriel_ Thanks for the image. And thanks again to @Asti for the solution. Turning off Enable User Mentioning fixed the problem.

Share: