wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

WPDiscuz and WPML issues


rrd
Posts: 8
 rrd
Topic starter
(@rrd)
Active Member
Joined: 1 year ago

Hello,

 

I use Wpdiscuz and WPML on my website and for now it is not 100 % working.

 

The comments only appear on the English page. When I change the language of my website, only the number of comments appear but not the comments. What could be the problem?

 

Also, a few of the Comments strings don't appear translated. The number of comments, "delete all my comments" and so on do not appear translated. What is the issue?

Is it possible to set the captcha so that it is also translated according to the language selected?

 

Thanks.

Topic Tags
12 Replies
rrd
Posts: 8
 rrd
Topic starter
(@rrd)
Active Member
Joined: 1 year ago

I have some screeshots as well:

not translated
not translated2
Reply
5 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@rrd,

The comments only appear on the English page. When I change the language of my website, only the number of comments appear but not the comments. What could be the problem?

This is a known issue. WPML and most other ML plugins don't support this. However, there is some workaround for this problem. Please check this WPML support topic:

https://wpml.org/forums/topic/show-comments-in-all-languages/

wpDiscuz has no chance to do this, it should be managed from WPML and WordPress side.

Also, a few of the Comments strings don't appear translated. The number of comments, "delete all my comments" and so on do not appear translated. What is the issue?

You should make sure the "Use Plugin .PO/.MO Files" option is enabled and the strings are already translated to the current language. 

Reply
rrd
 rrd
(@rrd)
Joined: 1 year ago

Active Member
Posts: 8

@asti,

This is a known issue. WPML and most other ML plugins don't support this. However, there is some workaround for this problem. Please check this WPML support topic:

https://wpml.org/forums/topic/show-comments-in-all-languages/

wpDiscuz has no chance to do this, it should be managed from WPML and WordPress side.

But before using wpdiscuz, everything was fine. The English comments appeared on the English page, the Spanish comments on the Spanish page and so on. Now that I'm using wpdiscuz they all only appear on the English version of the website. 

You should make sure the "Use Plugin .PO/.MO Files" option is enabled and the strings are already translated to the current language. 

I already made sure of it before posting something here. The strings are translated and the option is enabled. Is there a setting somewhere that block the strings to appear translated?

 

Also, the Live commenting and the Bubble - Invite to comment in X seconds don't work at all. Any ideas?

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@rrd,

Please leave some example URL. 

Reply
rrd
 rrd
(@rrd)
Joined: 1 year ago

Active Member
Posts: 8

@asti

Is it possible to live chat?

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@rrd,

Don't follow you well. Would you like to send the link privately? 

Reply
rrd
Posts: 8
 rrd
Topic starter
(@rrd)
Active Member
Joined: 1 year ago

yes

Reply
rrd
Posts: 8
 rrd
Topic starter
(@rrd)
Active Member
Joined: 1 year ago

if someone has an idea, it is more than welcome. Can't fix the issue with the comments not appearing

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@rrd,

As I've already mentioned you should deactivate the plugins one by one and check after each deactivation to find a problem maker. This is a plugin conflict for sure. 

Reply
rrd
Posts: 8
 rrd
Topic starter
(@rrd)
Active Member
Joined: 1 year ago

@asti
As I've already told you, I don't need to deactivate the plugins one by one as the problem comes from the compatibility between wpdiscuz and wpml... which is the title of my post. Something stops the comments from appearing on the pages not in the main language. And I'm also not the first having issues according to many posts of many forums. 

Can the wpdiscuz team get in touch with the compatibility team of wpml to resolve the issue?

Reply
rrd
Posts: 8
 rrd
Topic starter
(@rrd)
Active Member
Joined: 1 year ago

@asti
For now, the only way is to check "do not make posts translatable" in the post editor. The comments then appear on each post no matter the language but every posts of every languages appear also.

do not make posts translatable

 

Reply
Kolicoski
Posts: 4
(@kolicoski)
New Member
Joined: 8 months ago

Hi Guys, 

Is there any update on this? I'm having the same problem. "Initiate AJAX loading after page" works only for the main language. For the other languages only the number of comments is displayed and the comments are missing. 

If I'm logged to the admin, the comments are displayed properly for all languages. 

Right now I've set "Load with page" option as this is working fine but I would like to load the comments with Ajax when this bug is resolved. 

Reply
Share: