wpDiscuz - WordPress Comment Plugin
Submit button does ...
 
Share:
Notifications
Clear all

[Solved] Submit button does not confirm or refresh

14 Posts
2 Users
1 Likes
319 Views
ddewitt
Posts: 7
Topic starter
(@ddewitt)
Active Member
Joined: 5 months ago

When submitting a comment with wpDiscuz I get an error in the console.

The comment is submitted but there is no confirmation and the comment form isn’t refreshed to show the new comment. It just shows the loading animation for a second, then nothing else. If you click submit again, it says it's a duplicate.Β 

I tried default WP 2022 theme with all other plugins disabled - same problem.

comments error1
comments error2
comments error3

Β 

It is an intranet so I cannot share the website. I've included screenshots.

Thank you.

13 Replies
Asti
Posts: 5516
 Asti
Support
(@asti)
Illustrious Member
Joined: 5 years ago

@ddewitt,

Something blocks the native WordPress admin-ajax.php file.

Please check your security plugins' options and make sure they don't block the WordPress AJAX. This could be also blocked by the .htaccess file.

First please deactivate the plugins one by one and check after each deactivation, so you'll find a problem maker.

This also can be done by the server-side. If none of the plugins caused the issue please contact the server support and ask them to check the access of the admin-ajax.php file.

ddewitt
Posts: 7
Topic starter
(@ddewitt)
Active Member
Joined: 5 months ago

WP Engine confirms nothing is blocking access of the admin-ajax.php file.

3 Replies
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5516

@ddewitt

First please deactivate the plugins one by one and check after each deactivation, so you'll find a problem maker.Β 

What about this point?Β 

ddewitt
(@ddewitt)
Joined: 5 months ago

Active Member
Posts: 7

@asti Sorry. I mentioned in my original post - I already moved to a default theme and tried turning off each plugin. No joy.

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5516

@ddewitt,

Please create a dev/staging copy of your website in some sub-domain, make sure the problem exists and send admin details to info[at]gvectors.com email address.

You can use Duplicator to create that site.Β 

ddewitt
Posts: 7
Topic starter
(@ddewitt)
Active Member
Joined: 5 months ago

Done

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5516

@ddewitt,

Please provide us with the login details for the pop-up login as well.Β 

image
ddewitt
Posts: 7
Topic starter
(@ddewitt)
Active Member
Joined: 5 months ago

Sorry about that. I've removed that login step for you.

2 Replies
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5516

Thank you @ddewitt,

The developers are checking the issue. I'll update this topic once I get some news for you.Β 

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5516

@ddewitt,

The issue is fixed on the staging website. It was a small issue within the wpDiscuz plugin, it'll be fixed in the next version.Β 

You can install the version from the staging website on the live site. It'll work fine.Β 

ddewitt
Posts: 7
Topic starter
(@ddewitt)
Active Member
Joined: 5 months ago

Could you send me a link to download the fixed version? I had to delete most of the posts and pages for the staging site because it had confidential info. Thank you.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5516

@ddewitt,

The new version is ready. Just update the plugin to the latest version.Β 

ddewitt
Posts: 7
Topic starter
(@ddewitt)
Active Member
Joined: 5 months ago

Terrific! It's working well now. Thanks for your efforts. You can close this thread.

Share: