wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Social login needs page refresh/reload to work


Eduardo Chaves
Posts: 6
Topic starter
(@eduardo-chaves)
Active Member
Joined: 6 months ago

Hi,

I recently opened a topic on wpDiscuz WordPress forum about my problem and I received a reply but after my answer for that I didn't receive any feedback since my last answer (3 days ago). So I'm here to keep trying to solve my problem.

The reply I received on that topic was to follow a topic from here that was about the same problem of me.

But I had a doubt about the steps this topic said to follow, if it was to delete the files from my server or to some how delete from my cache plugin settings (W3 Total Cache).

Anyway I first deleted from my server arquives and then purged/refreshed my website to see if it worked. But it didn't... So I went to my cache plugin settings to see if there was somewhere I could delete those files from caching, but as I'm not a advanced WordPress user I didn't find a way to do it.

So I ask for help so you guys help me on this...

PS.: Any more information about my problem are in those two topics I put the links.

Thanks,
Eduardo Chaves

Topic Tags
10 Replies
Asti
Posts: 3337
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

@eduardo-chaves,

You should exclude the following two files from your caching plugin: 

/wp-content/plugins/wpdiscuz/assets/wpdiscuz-social.js
/wp-content/plugins/wpdiscuz/assets/wpdiscuz.js

This article should be helpful for you:

https://www.webnots.com/exclude-pages-and-directories-from-caching-in-w3-total-cache/#text=How%20to%20Exclude%20Pages%20and,Never%20cache%20the%20following%20pages%E2%80%9D.

Eduardo Chaves
Posts: 6
Topic starter
(@eduardo-chaves)
Active Member
Joined: 6 months ago

Hi @asti,

I looked at this article and tried to put in those 4 ways in my plugin settings, but no one of them worked... did I do something wrong?

PS.: I purged my website and google chrome cache in each way I tried.

The ways I tried:

Screenshot 1
Screenshot 2
Screenshot 3
Screenshot 4

 

Thanks,
Eduardo Chaves

 
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

@eduardo-chaves,

Could you please just for testing reason deactivate the cache plugin and check again? 

Eduardo Chaves
Posts: 6
Topic starter
(@eduardo-chaves)
Active Member
Joined: 6 months ago

@asti,

I deactivated and the problem keeps the same, I deactivated two other plugins I have (Asset CleanUp: Page Speed Booster; Autoptimize) just to make sure they wasn't caching, but the stays the same...

PS.: I have Cloudflare CDN and plugin on my website, just to add information.

Kind Regards,
Eduardo Chaves

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

Hi Eduardo Chaves,

PS.: I have Cloudflare CDN and plugin on my website, just to add information.

This makes sense. Once you exclude the JS files from the plugin settings purge your CDN before checking. If it still doesn't work, you should find some way to exclude the files from CDN caching. 

Eduardo Chaves
Posts: 6
Topic starter
(@eduardo-chaves)
Active Member
Joined: 6 months ago

So @asti...

I just tried purging the cache and nothing changed, so I tried to exclude the files from Cloudflare caching and again nothing changed.

I think I'll have to notify in every post to my users they have to refresh the page every time they login in their social accounts. Cause this problem is really complicated to fix...

Follow some prints:

Screenshot 1

Here is how I deleted the files from Cloudflare caching:

Screenshot 2

 

Thanks,
Eduardo Chaves

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

@eduardo-chaves,

I may also suggest you try the following solution: https://wpdiscuz.com/community/postid/1650/

Eduardo Chaves
Posts: 6
Topic starter
(@eduardo-chaves)
Active Member
Joined: 6 months ago

Hi @asti,

This link leads to a 404 Page...

Kind Regards,
Eduardo Chaves

2 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

@eduardo-chaves,

Please try it now. 

Eduardo Chaves
(@eduardo-chaves)
Joined: 6 months ago

Active Member
Posts: 6

Thanks @asti,

It solved my problem!

Thank you,
Eduardo Chaves

Share: