The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
only default (gr)av...
 
Share:
Notifications
Clear all

Bug [Solved] only default (gr)avatar showing for all users

4 Posts
2 Users
1 Reactions
396 Views
Posts: 6
Topic starter
(@maryann-johanson)
Active Member
Joined: 9 months ago

This is a recent issue, but I cannot pinpoint precisely when it began:

When wpDiscuz is activated, anyplace there should be a user (gr)avatar shows only the default avatar. So, in the commenting field, and also when displaying live comments:

discuz1

 In the backend listing of users:

discuz2

Even in the listing of options for which avatars to show, and also even my own gravatar as site admin (top right corner):

discuz3

This is definitely a wpDiscuz issue. There is no conflict with another plugin or with my theme (I tested all of that). When wpDiscuz is deactivated, the (gr)avatars everywhere show as they should.

My site is on the latest version of WP: 6.3.2. and the latest version of wpDiscuz: 7.6.10. (I am using some wpDiscuz addons, which are also all up to date, but testing shows that it isn't any of the causing the problem). This version of wpDiscuz has not been tested with this version of WP, and I held off updating wpDiscuz because of that, but this issue predates my updating the wpDiscuz plugin. (I updated finally because I thought it would solve the problem. It hasn't.) I'm not using any caching plugins, but I have cleared the caches within wpDiscuz.

I'm really stumped. Any help would be greatly appreciated. Thanks!

 

3 Replies
Posts: 65
Support
(@zackar)
Trusted Member
Joined: 9 years ago

Hi @maryann-johanson

it will be fixed in the next version

Posts: 6
Topic starter
(@maryann-johanson)
Active Member
Joined: 9 months ago

I've just found a workaround for anyone interested. Go to wpDiscuz > Settings > Comment Thread Features. Make sure the fields for Default Avatar Source URL for Users and Default Avatar Source URL for Guests are BLANK (I had a link to my own default icon there) and also uncheck Enable Sitewide Usage of Default Avatars. For now, for me, at least, this got my (gr)avatars back.

1 Reply
(@maryann-johanson)
Joined: 9 months ago

Active Member
Posts: 6

wpDiscuz is a really powerful plugin, which is great! 😋 But it does mean that with all the options, it can be really difficult to narrow down a problem. 🤔 

Share: