wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] How can I disable wordpress site login on plagin


useranik12
Posts: 1
Topic starter
(@useranik12)
New Member
Joined: 1 year ago

I want to disable wp login on comment section 

6 Replies
Asti
Posts: 3580
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

Hi @useranik12,

You should disable the 'Show "Login" link on comment form' option. The option is located in the Dashboard > wpDiscuz > Settings > User Authorization and Profile Data admin page. 

More info here: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/user-authorization-and-profile-data/#show-%E2%80%9Clogin%E2%80%9D-link-on-comment-form

3 Replies
Citizens Journal
(@citizens-journal)
Joined: 8 months ago

New Member
Posts: 3

In the latest release, shutting off the login link will still not let us disable the login requirement. Please help.

WPDiscuzLoginDisable
Citizens Journal
(@citizens-journal)
Joined: 8 months ago

New Member
Posts: 3

More:

We can do comments if already logged in, but not if we aren't.

Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3580

@citizens-journal

We can do comments if already logged in, but not if we aren't.

Please clarify a bit. It'd be better if you leave some example URL to allow us better understand the issue. 

Citizens Journal
Posts: 3
(@citizens-journal)
New Member
Joined: 8 months ago

OK.

Here's a sample post to attempt a reader comment:
https://www.citizensjournal.us/fda-panel-votes-to-recommend-johnson-johnsons-coronavirus-vaccine-for-emergency-authorization/

 

If you aren't logged in to WP, it tells you to (see attachment)

PleaseLogin

, but we have the login link turned off (see image in one of my previous comments above)

We are using the latest WPDiscuz release, with WP 5.5.3.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3580

@citizens-journal,

You can use the CSS code below:

#wpdcom .wpd-form-wrap .wpd-login-to-comment {
    display: none;
}

Put the code in the Top Admin Bar > Customize > Additional CSS > "Additional CSS" textarea, save it, delete all caches and check again.

Please don't forget to press Ctrl+F5 (twice) on the frontend before checking.

Share: