wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Copy over to testing server broke wpDiscuz


jharries
Posts: 9
Topic starter
(@jharries)
Active Member
Joined: 1 year ago

Good Day,

I have wpDiscuss working fine on my production site here: https://www.morganscloud.com/2020/12/04/firefly-carbon-foam-batteries-are-great-but-read-the-fine-print/

However I copied that site over to my staging and development server using UPdraft backups migration feature, which I do all the time and works fine. That plugin goes through the data base and migrates the site URL. 

 

But that broke wpDiscuz because it can't seem to find the CSS file it needs so there is no formatting See screen shot below

Please understand that I do this migration all the time and all other plugins work fine, amd I have a BUNCH of them because we are a membership site.

wpDiscuz is throwing the following errors in Wordpress debug:

Notice: Undefined index: /usr/home/jharries/public_html/aac_wordpress/wp-content/plugins/wpdiscuz/themes/default in /usr/home/jharries/public_html/aac-wordpress2_test/wp-content/plugins/wpdiscuz/utils/class.WpdiscuzHelper.php on line 313

Notice: Trying to access array offset on value of type null in /usr/home/jharries/public_html/aac-wordpress2_test/wp-content/plugins/wpdiscuz/utils/class.WpdiscuzHelper.php on line 313

 

And in the browser it is looking for a CSS file in the root directory, instead of within wpDiscuz: See screen shot below.

 

I have tried:

  1. Deleting wpDiscuz and reinstalling it from the wordpress plugins repository
  2. The standard 2020 theme.
  3. Turning off all other plugins.
  4. Clearing all options in wpDiscuz

None of these help.

Seems like the plugin is keeping the old URL somewhere strange (not the data base) so it has a problem when being moved.

Please advise how to fix this since I need to be able to move my production site to a staging site.

 

Thanks

John

Screen Shot 2020 12 11 at 5.06.27 PM
Screen Shot 2020 12 11 at 5.07.09 PM

 

 

 

Topic Tags
2 Replies
Asti
Posts: 3901
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

Hi @jharries,

Please navigate to Dashboard > wpDiscuz > Forms admin page, edit the form, and just click on the "Update" button. Then delete all caches and check again. 

jharries
Posts: 9
Topic starter
(@jharries)
Active Member
Joined: 1 year ago

Good Morning,

That fixed it. Thanks very much. 

John

Share: