The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
I cannot add more t...
 
Share:
Notifications
Clear all

Issue [Solved] I cannot add more than one specific page ID for a form

10 Posts
2 Users
0 Likes
113 Views
Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

I do not want comments on certain pages. But I do want them on a few. So I set up the "page" form for, intially, one page ID. And it worked, showing the comment form just on that page.

But then I had additional pages on which I wanted to display comments. So I entered the additional page IDs, comma separated.

But they don't show on the initial pages.

I'm not sure if it makes a difference, but whenever I save, it adds a space after the comma in the list, where I didn't have one in the first place.

Is there a way to fix this?

Thanks

9 Replies
Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Additionally, yes, I have comments turned on for the page in the editor.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 7095

@cheryld,

Please provide us with a detailed list of the steps you've taken to allow us to replicate the same issue on our test websites for further investigation.

Additionally, it would be better if you could record a video demonstrating the issue for better clarity.

I'm not sure if it makes a difference, but whenever I save, it adds a space after the comma in the list, where I didn't have one in the first place.

This is normal behaviour. 

Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Thanks for clarifying about the commas. I did do a screen recording, but I'm not sure what it will show you:

https://nimb.ws/CkqBrOw

The issue that only the first page in the list of page IDs, here, is getting the comment form. I've tried it on other pages (with comments enabled in the page settings) and they do not get the comment form.

So, to be specific, if I have the following page IDs in the form:

62824, 76705, 76707, 76709, 76714, 76716, 76719, 80977, 83517, 86847

Only page 62824 gets the comment form. I've tried to go in and enable comments in the page settings for a couple of other pages in this list of pages that will get comments as I edit them, so far, but none but the first gets the form.

Thanks

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 7095

@cheryld,

We don't find such an issue on our test websites. Could you please send the admin login details to info[at]gvectors.com email address? I'll ask the developers to check the issue for you.

Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Hmmm. I tried enabling comments for every page with the default form and they still weren't appearing on the other pages. I'm going to take a look around and see if there's something I added somewhere else that would have removed the comments from these specific pages at one point.

 

If I create a new page, the comments show.

Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Yeah, there's something in the body of some of the pages I was trying to put a comment form on. I removed everything, saved -- and the comment form appeared. Now I need to figure out what it is.

Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Well, I couldn't figure out why. These are just a few, specific, pages where the comment form does not want to show. All I can figure is that these specific pages are homepage-like pages with a lot of query blocks. I manually added the WP Discuz form in there and now it's there -- the comment bubble doesn't show but, strangely, the article rating at the top showed when the comment form would not.

Thanks

Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Solved it. The pages where the comments would not show had a shortcode from the Buddypress group type plugin on them. That was somehow conflicting with the comments.

Thanks.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 7095

@cheryld,

Thank you for letting us know. Glad to hear that the issue is solved.

We're going to mark this thread as resolved. Feel free to open a new topic if you have further questions.

Share: