The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
Share:
Notifications
Clear all

Comment form issue

25 Posts
2 Users
0 Reactions
179 Views
Posts: 13
Topic starter
(@navisidhu)
Active Member
Joined: 3 weeks ago

Question -

Hi, The wp discuz form is not working properly on my website.Β 
Kindly help, I have attached the screenshot. It is not showing the form such as Name, email, comment section.Β 

24 Replies
2 Replies
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

Please check the points mentioned in this doc and leave some feedback on each point: https://wpdiscuz.com/docs/wpdiscuz-7/getting-started/missing-comment-form/

Reply
Posts: 13
Topic starter
(@navisidhu)
Active Member
Joined: 3 weeks ago

Hi Asti,

I have checked everything. Nothing works.

Reply
Posts: 13
Topic starter
(@navisidhu)
Active Member
Joined: 3 weeks ago

Here is the page url, where you can see the issue.
https://goatmetrics.com/boxing/

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check the issue for you.

Reply
Posts: 13
Topic starter
(@navisidhu)
Active Member
Joined: 3 weeks ago

Logins sent via email from web.navdeep2017@gmail.com

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

We don't find an email from you. Please check and make sure you've sent the email to the correct email address (mentioned here).Β 

Reply
Posts: 13
Topic starter
(@navisidhu)
Active Member
Joined: 3 weeks ago

I have emailed again at info@gvectors.com

Reply
12 Replies
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhu

The user doesn't have admin access. It appears to be just a regular user.

Reply
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13

@asti I have changed,Kindly have a look now.

Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

Now everything is fine. I've already asked the developers to check the issue. I'll update this topic once I get a response from them.

Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

We have to ask you to create a dev/staging copy of your website in some sub-domain and send admin details to info[at]gvectors.com email address.

You can useΒ DuplicatorΒ to create that site. It's too hard to check the issue on your live website.Β 

Reply
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13

@asti Sent

Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

Thank you, @navisidhuΒ 

We'll check and get back to you soon.

Β 

Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

Hi,

The issue is fixed on your staging website. Somehow the comment_status was closed on your website. The developers have added the custom code in your active theme functions.php file. You'll need to insert it in the functions.php file.Β 

Then add the CSS code in the "Custom CSS Code" textarea.Β 

div#comments{display:block!important;}
Reply
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13

@asti Yes It works but.

Thanks for submitting the comment is always showing here. It should show only after when the user added a comment.

image
Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhu

You've added the section using custom code, so the issue is related to that custom code. You should check the code and make sure it's correct.

Alternatively, you can use the built-in wpDiscuz "Redirect First Comment To" option. More information can be found here: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/general-settings/#redirect-first-comment-to

Reply
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13

@asti But the custom code section is used only for adding shortcode. Before it was using same thing, and the form is working good "Whithout showing -Thanks for submitting your comment" all time.

Please have a look again and fix it.

Reply
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13

@asti I am waiting for your reply.

Apart from that, I need to know when I can setup the role permission, I want that only members can comment using this form, if another user try to fill the form then "Login" or "Register" option should show.

Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

Please leave here the code you're using. I'll ask the developers to check it.

Reply
Posts: 13
Topic starter
(@navisidhu)
Active Member
Joined: 3 weeks ago

[wpdiscuz_comments] I am using this shortcode

Reply
2 Replies
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7334

@navisidhuΒ 

I mean the custom code you used for displaying the "Thanks for submitting your comment" message.Β 

Reply
(@navisidhu)
Joined: 3 weeks ago

Active Member
Posts: 13

@asti [wpdiscuz_comments]Β  I only used this code, everything is automatically coming.

Before "Thanks for submitting your comments" was not showing everytime, It was only showing when customer submit the comments.

Now after your development team added some code in function.php, It is showing regularly. Kindly fix that glitch.

Reply
Asti
Posts: 7334
 Asti
Support
(@asti)
Illustrious Member
Joined: 7 years ago

Posted by: @navisidhu

Before "Thanks for submitting your comments" was not showing everytime, It was only showing when customer submit the comments.

wpDiscuz doesn't have such a feature. This is done through custom code. We need to know what code you have used.

Reply
Share: