Comment form/Commen...
 
Share:
Notifications
Clear all

Comment form/Comments not showing when logged out

20 Posts
3 Users
0 Likes
1,822 Views
Posts: 10
Topic starter
(@kweber)
Active Member
Joined: 3 years ago

Hello! I love the wpdiscuz plugin, but it does not seem to be working properly on my site. It shows up at the bottom of pages when logged in, but not when you are logged out. I have the setting marked to allow guests to comment. Any help would be greatly appreciated!

19 Replies
Asti
Posts: 6987
 Asti
Support
(@asti)
Illustrious Member
Joined: 6 years ago

@kweber,

Please leave some example URL to allow us to check the issue. Also leave a screenshot of the "Allow guests to comment" section. 

Reply
Posts: 10
Topic starter
(@kweber)
Active Member
Joined: 3 years ago

Thanks for getting back to me so quickly. Here is a link to the page that it should be showing on: http://tvfresourcecenter.wordpress-prod-linode-7.imavex.net/article/fiber-types-and-traits/

 

Attached are two screenshots. One shows the settings to show for guests and the other shows the section showing when you are logged in.

CommentsLoggedIn
Settings

 

Reply
11 Replies
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6987

@kweber,

It seems the comments_template function is not called for guests. I may suggest you to deactivate the plugins/theme one by one and check after each deactivation to find a problem maker.

Also check the settings of the LearnDash plugin, probably there is also some setting that hides the comments from guests. 

Reply
(@kweber)
Joined: 3 years ago

Active Member
Posts: 10

@asti I was able to get the comments section to show at the bottom of the page, but now it doesn't show the comments. I can see on the example page below that there are two comments, but I can't see the comments. They have been approved on the backend.

http://tvfresourcecenter.wordpress-prod-linode-7.imavex.net/article/cotton-grades/

 

Thanks,

Kristen

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6987

@kweber,

Please disable the focus mode of Learndash plugin and check again. 

Reply
(@kweber)
Joined: 3 years ago

Active Member
Posts: 10

@asti Removing the focus mode did work, but I need that on. So is this a LearnDash problem then?

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6987

@kweber,

It'd be better if you contact the LearnDash plugin support with this issue. 

Reply
(@kweber)
Joined: 3 years ago

Active Member
Posts: 10

@asti LearnDash pointed out that the comments show when the comment plugin is disabled. @ueharasuemi21 found that you can see the comments when you click on 'Newest' or 'Most Voted'. It seems its a problem or setting in wpdiscuz, but I haven't been able to figure it out. Could you please assist?

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6987

@kweber,

As I've already mentioned, you should contact the LearnDash plugin support with this issue. 

Reply
(@kweber)
Joined: 3 years ago

Active Member
Posts: 10

@asti I have contacted them and they said the comments show when wpDiscuz is not activated, so they are saying the problem is with wpDiscuz (your third party comment plugin). I found this online ticket, where you asked Cassidy to send an email to your team. Were they able to help her resolve this issue?

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6987

@kweber,

The only thing we can suggest you is disabling the focus mode of Learndash plugin.

Reply
(@ueharasuemi21)
Joined: 3 years ago

New Member
Posts: 4

@kweber I can see the comments only if I click on Newest or Most Voted. Maybe if you check the configuration on this filter...

Reply
(@kweber)
Joined: 3 years ago

Active Member
Posts: 10

@ueharasuemi21 Thank you. I am not seeing any settings that would enable them to show or that would have the "newest" posts show first.

Reply
Posts: 4
(@ueharasuemi21)
New Member
Joined: 3 years ago

Hi @kweber! I'm having the same issue. Could you find a solution?

Reply
4 Replies
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6987

@ueharasuemi21,

Have you deactivated the plugins/theme? 

Reply
(@ueharasuemi21)
Joined: 3 years ago

New Member
Posts: 4

@asti Hi. I'm going to try that. Thanks!

Reply
(@kweber)
Joined: 3 years ago

Active Member
Posts: 10

@ueharasuemi21 I did find a solution. I had to add some code to the functions.php file, but it had to do with LearnDash. If you do not have LearnDash, then the function would not work for you.

 

add_filter(
'learndash_focus_mode_can_view_comments',
function( $can_view_comments = false ) {
if ( ! is_user_logged_in() ) {

// Alternate example check the course price type. If 'open' allow comments.
$course_id = learndash_get_course_id();
if ( ! empty( $course_id ) ) {
$course_price_type = learndash_get_setting( $course_id, 'course_price_type' );
if ( 'open' === $course_price_type ) {
$can_view_comments = true;
}
}
}

// Always return $can_view_comments.
return $can_view_comments;
},
30,
1
);

Reply
(@ueharasuemi21)
Joined: 3 years ago

New Member
Posts: 4

@kweber I'm not using LearnDash but thanks for the reply!

Reply
Posts: 10
Topic starter
(@kweber)
Active Member
Joined: 3 years ago

If anyone else is having this problem, what I finally found that worked for me was going to 'Comment Thread Displaying' in the settings and under 'Comment List Loading Type' changing it to 'Initiate AJAX loading after page'. Hope this helps, for I spent way too much time on this debugging with no help from wpDiscuz!

Reply
Share: