wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

Comments Aren't Displayed


Cassidybrynn1
Posts: 8
Topic starter
(@cassidybrynn1)
Active Member
Joined: 10 months ago

Hello! I'm a huge fan of WPDiscuz, but lately I've been having some issues with comments not displaying. It appears as though the comments don't show until the reader comments? I've gone through all of the settings and can't seem to figure out why. I would like all of the comments to load, and then load as lazy scroll. I don't want the user to have to click anything to read them. 

 

I have comments on this page so you can see what it looks like now: https://www.hippieonholiday.com/advanced-keyword-research-training/

 

Thanks!

Topic Tags
9 Replies
Asti
Posts: 3943
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

@cassidybrynn1,

Please deactivate the cache plugin and check again. Let us know if the cache plugin caused the issue. 

Reply
Cassidybrynn1
Posts: 8
Topic starter
(@cassidybrynn1)
Active Member
Joined: 10 months ago

Hello, 

 

I went ahead and deactivated my caching plugin. The issue is still persisting, no change. 

Reply
2 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3943

@cassidybrynn1,

Then you'll need to deactivate the plugins one by one and check after each deactivation to find a problem maker. 

Please keep the cache plugin deactivated in the testing process.

Reply
Cassidybrynn1
(@cassidybrynn1)
Joined: 10 months ago

Active Member
Posts: 8

@asti The thing is I actually just moved to a new site and already activated the plugins 1 by 1. I will try again starting with WP Discuz now... 

 

With ALL other plugins deactivated the issue with the comments persists. 

 

Reply
Cassidybrynn1
Posts: 8
Topic starter
(@cassidybrynn1)
Active Member
Joined: 10 months ago

I tried changing it from lazyload to "view comments" and the view comments button still won't make the comments appear. The only way I can get comments to appear is by clicking the "oldest" or "newest" sort setting.

Reply
Cassidybrynn1
Posts: 8
Topic starter
(@cassidybrynn1)
Active Member
Joined: 10 months ago

Also, I love the inline commenting feature but hate the "Read More" that appears over the comment. Is there a way to disable this?

Reply
3 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3943

@cassidybrynn1,

You can use the CSS code below:

#wpdcom .wpd-comment-text .wpd-inline-feedback-wrapper {
display: none;
}

Put the code in the Top Admin Bar > Customize > Additional CSS > "Additional CSS" textarea, save it, delete all caches and check again.

Please don't forget to press Ctrl+F5 (twice) on the frontend before checking.

Regarding the first question. Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check the issue for you. 

Reply
Cassidybrynn1
(@cassidybrynn1)
Joined: 10 months ago

Active Member
Posts: 8

@asti

Thanks for that code! Definitely looks a lot nicer. 

 

Sending the email now. Thank you for helping me fix this!

Reply
kweber
(@kweber)
Joined: 6 months ago

Active Member
Posts: 10

@cassidybrynn1 Were you able to resolve the issue of the comments not showing until you clicked on the sort settings? I am having that same problem and Asti is telling me it's not a problem with their plugin. Thanks for any help you can provide!

Reply
Share: