wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

Untranslatable


Igor
Posts: 2
 Igor
Topic starter
(@theigor)
New Member
Joined: 2 months ago

Plugin is breaking several rules in terms of good translation practice.

  1. It's using string concatenation instead of placeholders.
    Because of this I end up with mixed order of words in sentences. For example in my language it looks as if someone would write "ago hours 3" in English. If string was using standard placeholders "%s ago" it would be easy to adjust in all languages.
  2. Not using built in translation functions like `_n` for plural form.
    Asking if something is 1 or not is just not good enough to implement plural words.
  3. Maybe use `human_time_diff` from WordPress or if not suitable at least use translations strings the same way that they do?

Any chance these can get addressed? Because it is simply not possible to translate properly the way it's done now.

Topic Tags
2 Replies
Asti
Posts: 3860
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

Hi Igor,

You can use the Structure of Human Readable Date Format option More info here: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/general-settings/#structure-of-human-readable-date-format

Also, we may suggest you use the WordPress Date/Time Format. If you want to switch to WordPress Format, just enable the according option in the Dashboard > wpDiscuz > Settings > General Settings tab 

Reply
Igor
Posts: 2
 Igor
Topic starter
(@theigor)
New Member
Joined: 2 months ago

I know about those options. I was talking more in terms of me contributing with translation over at translate.wordpress.org, it's just not possible to make a good translation.

That human readable time was just an example, there is more of this stuff.

 

Anyway here is the way plural forms are used in various languages:
http://docs.translatehouse.org/projects/localization-guide/en/latest/l10n/pluralforms.html?id=l10n/pluralforms

As you can see there are about 20 languages that have more than 2 forms and their output looks retarded when forced through "n != 1" rule.

Reply
Share: