wpDiscuz - WordPress Comment Plugin
Need to double Ente...
 
Share:
Notifications
Clear all

Need to double Enter to add a /line breaks when adding images through "Image Source URL to Image Conversion"


lazylonewolf
Posts: 8
Topic starter
(@lazylonewolf)
Active Member
Joined: 7 months ago

Not sure if it's actually wpDiscuz bug, just Wordpress, or just me, sorry in advance.

I'm not using any Add-ons yet.

So... I have "Image Source URL to Image Conversion" active so the commenters can still display images since I don't want people to upload media to my server (limited space).

The problem is that if you copy+paste an image URL without double Enter, the image will display right next to the text you typed-in, if any. It'll only add a line break with a double Enter between the text and image.

Double Enter

Single Enter or no Enter (just a space between the text and image), is the same result.

Single Enter
No Enter
5 Replies
Asti
Posts: 3624
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

Hi @lazylonewolf,

Please leave a direct link to this comment. We'll try to provide some CSS solution for this. 

Reply
4 Replies
lazylonewolf
(@lazylonewolf)
Joined: 7 months ago

Active Member
Posts: 8

@asti https://cat-nine.net/comic/episode-3/84-theres-myan/

Huh, did you guys somehow do something? It seems to be working now with single Enter, which adds <span> to do the line break.

But the <span> is visible until the page is refreshed.

span visible

 I've tested this on:

  • Cloudflare Dev mode active, and
  • W3 Total Cache: Browser and Page cache active. Minify active.

EDIT:

No <span> at all if Cloudflare Dev mode is inactive. Perhaps Cloudflare's the culprit?

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@lazylonewolf,

One of the active plugins/theme adds the noscript tag and changes the HTML structure. Please watch this video to better understand what I mean. 

https://www.screencast.com/t/3YdrNL0XLN

You should deactivate the plugins one by one and change after each deactivation to find a problem maker. 

Reply
lazylonewolf
(@lazylonewolf)
Joined: 7 months ago

Active Member
Posts: 8

@asti Ah, that's lazyloading and/or JS WebP rewriting from EWWW Image Optimizer. I've disabled them for wpDiscuz comments and their images for now. Same result as far as I know.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@lazylonewolf,

We're not able to check the issue as far as we get the following error message: https://www.screencast.com/t/ODWfev8lYq5

Reply
Share: