wpDiscuz - WordPress Comment Plugin
AJAX loading after ...
 
Share:
Notifications
Clear all

[Solved] AJAX loading after page - WPML problem


Kolicoski
Posts: 4
Topic starter
(@kolicoski)
New Member
Joined: 1 year ago

Hi Guys, 

Our website https://www.coffeeness.de/ is using WPML plugin and we use wpDiscuz for the comments. 

So far we are very happy with your plugin but today I noticed one bug.

 

If I select "Initiate AJAX loading after page" as Comment List Loading Type the comments only work properly for the main language. (DE in our case). For all other languages the comments are not loading. Only the number of comments is displayed.

Screenshot 1

Funny thing is that everything works properly if we are logged in the admin. 

Same error is happening if we select "Display [View Comments] button" as Comment List Loading Type. 

Main language is working fine but for the other languages the comments are missing. 

 

Right now we are loading the comments with the page. Can you please try to fix this problem. 

 

 

Topic Tags
4 Replies
Asti
Posts: 4613
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

@kolicoski,

This issue is already solved. Please make sure you're using the latest version of the wpDiscuz plugin. 

Kolicoski
Posts: 4
Topic starter
(@kolicoski)
New Member
Joined: 1 year ago

Hi @asti 

We are using the latest 7.2 version of the plugin. 

The issue is not resolved on our end. 

 

Here is a link from our staging site where you can see that we are still having this problem and the issue is not resolved: 

https://staging-coffeeness.kinsta.cloud/nl/delonghi-dinamica-ecam-350-55-b-test/

 

If we set "Initiate AJAX loading after page" the comments only load on the original language, for example this page: 

https://staging-coffeeness.kinsta.cloud/delonghi-dinamica-test/

 

Can you please look into this again? 

If needed, I'll provide you with access to our staging site. 

 

Thanks 

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 4613

@kolicoski,

Please navigate to WPML -> Languages admin page and scroll down and enable the "Language filtering for AJAX operations" option. 

Kolicoski
Posts: 4
Topic starter
(@kolicoski)
New Member
Joined: 1 year ago

Thanks a lot @Asti

This worked. All good now. Thanks a lot for your great support. 

Share: