wpDiscuz - WordPress Comment Plugin
Fix conflict with F...
 
Share:
Notifications
Clear all

[Solved] Fix conflict with Fast Velocity Minify plugin


BROS
Posts: 6
 BROS
Topic starter
(@bros)
Active Member
Joined: 1 year ago

I am using Fast Velocity Minify plugin for files minification. When I upgraded WPDiscuz from version 5 to 7, I noticed that the comment form does not run on some pages: https://share.getcloudapp.com/5zuXgkp5

I went to the browser console and saw such an error:

footer-aa7768e7be1e13f416609c9aabcccf356dc73432.min.js:63 An error has occurred: ReferenceError: WpdEditor is not defined

    at https://mysite.com/wp-content/uploads/cache/fvm/1591036834/out/footer-aa7768e7be1e13f416609c9aabcccf356dc73432.min.js114

(anonymous) @ footer-aa7768e7be1e13f416609c9aabcccf356dc73432.min.js:63

I tried to purge the cache of the Fast Velocity Minify plugin, also I cleaned the WP Super Cache, but it didn't helped to fix issue.

The only thing that helped was to disable Load Min Versions option in General settings of the WPDiscuz and then clean the Fast Velocity Minify plugin's cache.

But I am still not sure if the comment form works on all pages of my site.

Should the Load Min Versions option be disabled when using the minification plugins to load comment form properly?

1 Reply
BROS
Posts: 6
 BROS
Topic starter
(@bros)
Active Member
Joined: 1 year ago

I solved this problem by excluding these files in Fast Velocity Minify plugin:

/wp-content/plugins/wpdiscuz/themes/default/style.css
/wp-content/plugins/wpdiscuz/assets/css/wpdiscuz-combo.min.css
/plugins/wpdiscuz/assets/js/wpdiscuz-combo.min.js

But maybe there is some way to make the minification plugin and WPDiscuz work together normally?

Reply
Share: