wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Too many requests to gravatar servers after the update to new version!  


torey55z
Posts: 6
Topic starter
(@torey55z)
Active Member
Joined: 7 months ago

Hi, i updated the plugin from version 5.3.2 to the latest version. After the update i enabled gravatar caching as usual but when i load the page it makes more than 100 requests to gravatar server which is slowing down my webpages. This wasn't happening in the previous version (5.3.2) that i was using. I have a very busy site and users are complaining about the slow speed. Can you please help me out as i dont know what to do now. I have attached the screenshots of my settings.

wpd1
wpd2

 

Topic Tags
8 Replies
torey55z
Posts: 6
Topic starter
(@torey55z)
Active Member
Joined: 7 months ago

@asti can you please look into it and give me some suggestions if you can.

Thanks

torey55z
Posts: 6
Topic starter
(@torey55z)
Active Member
Joined: 7 months ago

i can see some other guy has the same problem and it wasnt resolved

https://wpdiscuz.com/community/bug-reports/gravatar-cache/#post-778

6 Replies
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1916

@torey55z,

Please wait a bit. I'll need to contact the developers before answering you. 

torey55z
(@torey55z)
Joined: 7 months ago

Active Member
Posts: 6

@asti Ok thanks. I am waiting patiently.

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1916

@torey55z,

Please change the value of the "Caching method" to the "runtime" and check again. 

 

torey55z
(@torey55z)
Joined: 7 months ago

Active Member
Posts: 6

@asti Thanks for the reply. The runtime method will cache avatars on page loading which will reduce the page speed on first load. Cron job method is what i want. I dont understand why it is not working. Do you have any idea of why its not working?

Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 1916

@torey55z,

The cronjob method works fine. There should not be any issues. Probably the time was not enough for caching?

torey55z
(@torey55z)
Joined: 7 months ago

Active Member
Posts: 6

@asti working now. Fixed it by reinstalling the plugin. Thanks for the help.

Share: