wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Custom Rating value mismatch with Geodirectory Rating

6 Posts
2 Users
1 Likes
143 Views
Cjhensle
Posts: 16
Topic starter
(@cjhensle)
Active Member
Joined: 4 months ago

I am using the Geodirectory theme on my directory website. For each listing/post, there’s is a rating widget installed.

The wpDiscuz comment form shows up perfectly fine in the comment section. The overall post rating value is correct. However, the Comment Total value is not correct. As you can see in the attached picture. There is more than 1 comment in this post, but only 1 showing.

In the Wordpress dashboard, when I look at all of the comments, I can see the custom rating field values correctly. I can click on Edit for a comment and it gives me an option to rate that comment (even if the wpDiscuz rating value is already there). So there is now two rating values for one comment like shown in the other picture attached. Only when I rate the comment in the WP comment dashboard, does the comment total update correctly. Hence the count of 1 shown in the picture.

Not sure how to fix this. Any help is greatly appreciated!

5 Replies
Asti
Posts: 5071
 Asti
Support
(@asti)
Illustrious Member
Joined: 5 years ago

@cjhensle,

First of all the attached image is missing. 

As far as we understand this is just a cache issue. Please try to deactivate the cache plugin and check again.

 

Reply
4 Replies
Cjhensle
(@cjhensle)
Joined: 4 months ago

Active Member
Posts: 16
20109AD8 1F4D 4ECC B9E5 230E291CC649
57882DD7 DFB5 4662 8AFB 1E1C616D68C7

@asti ok I’ll try that. Here are the pictures.

Reply
Cjhensle
(@cjhensle)
Joined: 4 months ago

Active Member
Posts: 16

@asti Deactivating the cache plugin and testing it didn't work.

Reply
Cjhensle
(@cjhensle)
Joined: 4 months ago

Active Member
Posts: 16

@asti Nevermind. There was a setting I found within the Geodirectory software to "Disable Reviews without Disabling Comments" that fixed the problem. Now, the correct number of comments are showing. Please disregard this topic and close it out. Thank you!

Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5071

@cjhensle,

Thank you for letting us know. Glad to hear that the issue is solved.

We're going to mark this thread as resolved. Feel free to open a new topic if you have further questions.

Reply
Share: