The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
User badges and how...
 
Share:
Notifications
Clear all

User badges and how they are assigned?

5 Posts
2 Users
0 Reactions
367 Views
Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

I'm working on the comment system a bit right now -- I don't have that many comments, but looking at how user badges are assigned, I responded to a recent comment and the badge is "Author" as I am the post author, and not admin. I noted that several of my very old comments said "guest" and I thought that perhaps it was because I had a different email at the time?

So I went in and edited the email under Comments and that changed the avatar but not the user badge -- it still says guest. Author is OK if I am the post author, but is there some way to fix the old comments I entered as admin so the user badge does not say "guest"?

Thanks

4 Replies
Asti
Posts: 7327
 Asti
Support
(@asti)
Illustrious Member
Joined: 7 years ago

Hi,

You should edit the comment/comments from the Dashboard > Comments section and change the email address to the admin one. 

Make sure the "Use guest email to detect registered account" option is enabled. 

Moreover, if you wish to change the "Author" table to "Admin" check out this FAQ: https://wpdiscuz.com/community/f-a-q/how-to-change-the-author-label-for-administrators/#post-20858

Reply
Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

Thanks for the reply, 

As I had mentioned, I already did go and try editing the email under "comments" and I do always keep the toggle for detect guest email to on. Still, it says "guest." But it's an isolated thing limited to a few comments, so I'm not going to worry about it as it shows the actual user badge for new comments.

As far as changing author to admin when it's an admin user -- thanks, that worked!

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7327

@cheryld,

As I had mentioned, I already did go and try editing the email under "comments" and I do always keep the toggle for detect guest email to on. Still, it says "guest." But it's an isolated thing limited to a few comments, so I'm not going to worry about it as it shows the actual user badge for new comments

Have you deleted the caches once you changed the email address? 

 

Reply
Posts: 26
Topic starter
(@cheryld)
Eminent Member
Joined: 3 years ago

I had cleared the object and regular cache several times. However, I had forgotten to clear the WP Discuz cache. I did so and the results are still the same. As I said, though, this is isolated to just a handful of comments, so I'm going to let it go. Thanks.

Reply
Share: