wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Troubles with translation of Bubble and comment form, and also scaled page rating on wpForo pages


Shukhrat Bobomuratov
Posts: 8
Topic starter
(@flakkandi)
Active Member
Joined: 2 years ago

Hi to all. I am new here so I don't know how I should start this article.
I love both your plugins wpDiscuz and wpForo. And have some issues I want to fix:

1. Recently I translated 100% of wpDiscuz plugin to Ukrainian language using .pot file and enabled using .po/.mo translation method in wpDiscuz settings. wpDiscuz settings page become fully translated and commenters profile too, but commenting form and Bubble still has only English translation look.

Zb7wPRIXIp
b4oy3BfRA3
mK7HhK50Ow
0QpjyFxHVv

 2. I enabled wpDiscuz post ratings and all single pages (wpForo too) of my site shows full screen-scalable stars with no functionality, how can I fix this issue or disable ratings for single pages?

Jlqi5950Ea
Wkc4jOWGlU
fmyDnY0vCP

3. Maybe it is a kind of off-topic, but when I chose custom login pages in wpForo it just brings me 404 issue page with address I chose.

OxVc0G0G78
Svc0blSeaS

4. I am creating a bilingual lifestyle blog. Can I use two separate versions of wpForo for each language? Or maybe it could support a few translations at one time?

Thank you so much for this great job. 
 

7 Replies
Shukhrat Bobomuratov
Posts: 8
Topic starter
(@flakkandi)
Active Member
Joined: 2 years ago

3. Issue detected - it only works for custom created pages (I didn't saw this for the first time when I set-up forum), sorry 🙂

Tom
Posts: 447
 Tom
Support
(@tomson)
Support Team
Joined: 6 years ago

Hi @flakkandi,

I think you have an old UK po file. Please update the UK PO file based on the new wpDiscuz 7 POT file again. Then search for those phrases again. Once you finish with the translation, upload and overwrite those PO/MO file to these directories:

  • /wp-content/languages/plugins/
  • /wp-content/plugins/wpdiscuz/languages/
  • /wp-content/languages/loco/plugins (if you have loco translate plugin)

 

Also, if you have multi-language website, you should create new comment form for UK language. Please follow tot this instruction: https://wpdiscuz.com/docs/wpdiscuz-7/getting-started/manage-comment-forms/comment-form-settings/#language

 

Regarding the BIG stars under the forum. Please make sure your forum uses a page not post. And the comment s are disabled for that page. These stars are the wpDiscuz 7 Article Rating stars, there is no wpDiscuz CSS style, so they look like that, they should not be loaded on this page. I think you have a hard-coded comment section in page template which cannot be disabled by forum.

 

 

 

Shukhrat Bobomuratov
Posts: 8
Topic starter
(@flakkandi)
Active Member
Joined: 2 years ago

Hi, @tomson.

1. After writing this article I found that I didn't create another form for en_US site language so I made it, and it helped me to translate input forms text and rating Title.

You were right that I have been used translation based on last .pot file (I copied it from 5.x and translated new ~600 strings). So I fully replaced it from 5.x .pot to new based on wpDiscuz 7 .pot - .po/.mo files, but it doesn't help. Then I copied these files in the whole three directories, you wrote above. But it still doesn't translate. Maybe I should wait for the next update with Ukrainian localization?

ELET6DFaW7
3ZDxg2pRij

2. I looked for all settings and my forum uses pages, not posts. Other pages in my blog show this scaled Stars too. I checked comments and star rating options and don't know how to disable it on pages.

87KwdhrtjU
1xawpJR7bR
oASMj8pa8a
4GWupB0DMX
q6QD6RYtek

 

Thank you again. Rewritten wpDiscuz-uk .po/.mo I send you on support@gVectors.com

(and working on wpForo translation)

 

4 Replies
Tom
 Tom
Support
(@tomson)
Joined: 6 years ago

Support Team
Posts: 447

@flakkandi,

We don't see such issues. All phrases are well translated on our side.

Please install a new WordPress with English language, then install the latest wpDiscuz 7 beta-8 and, then upload the translated PO/MO files to wpDiscuz plugin /languages/ directory.

Then go to Dashboard > wpDiscuz > Forms admin page. Edit the Default Form and set the Ukrainian language code.

After this go to Settings > General and change the WordPress language to Ukrainian.

 

Note. Please send the latest translated PO/MO files, so we could also check it on our websites.

 

Regarding the Rating Stars. Please change the option and use "Before Comment Form" option (the first option) and let me know if the problem is fixed.

Shukhrat Bobomuratov
(@flakkandi)
Joined: 2 years ago

Active Member
Posts: 8

@tomson

I will reinstall my Wordpress blog and create it's new version from scratch. After that I will write you here, does this issue is done. It may take up to week

I already mailed lastest translated PO/MO files on support@gvectors.com 😌 

By the way, I am gVectors new FAN ))

Tom
 Tom
Support
(@tomson)
Joined: 6 years ago

Support Team
Posts: 447
Shukhrat Bobomuratov
(@flakkandi)
Joined: 2 years ago

Active Member
Posts: 8

Hi, @tomson

I reinstalled WordPress and fully recreated my blog on the new modern theme and all works perfectly. 

Translation also looks great! If I will find some mistakes or better view of localization - I'll send it to your support email, ok?

Now work to finish wpForo localization. (And my platform for creators)

Thank you so much. You are breathtaking 😊 

Share: