wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Remove (@username) tag besides Username after installing add-on


orestto
Posts: 2
Topic starter
(@orestto)
New Member
Joined: 2 years ago

Hello,
I just installed the wpDiscuz User & Comment Mentioning add-on, and now I see a (@username) tag to the right of where the commenter's Username already appeared.

So now its: Avatar -> Username -> (@username).

How can I remove this newly added (@username) tag? It's unnecessary and in most cases simply duplicating of the first Username.

 

wpdiscuz support
6 Replies
Tom
Posts: 452
 Tom
Support
(@tomson)
Support Team
Joined: 7 years ago

Hi @orestto,

This comes from the wpDiscuz User & Comment Mentioning addon. This is the nickname that commenters use in comments to mention other users.

In any case if you want to disable it, please put this CSS code in the Top Admin Bar > Customize Menu > Additional CSS Tab > Custom CSS Code textarea. Save it and delete all caches:

#wpdcom .wpd-comment .wpd-comment-wrap .wpd-comment-author span.wpducm-user-nicename{
     display:none!important;;
}

 

1 Reply
thinhne
(@thinhne)
Joined: 6 months ago

New Member
Posts: 1

@tomson hi, can you show me how to delete it ?

tonyraven
Posts: 2
(@tonyraven)
New Member
Joined: 6 months ago

That css didn't work but this did:

.wpd-user-nicename {
display:none!important;;
}

3 Replies
paulcola
(@paulcola)
Joined: 1 year ago

Active Member
Posts: 5

@tonyraven Thank you for this. I noticed my Wordpress user login name being displayed (dangerous!) and this CSS fixed it. I appreciate it!

Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 4613

@paulcola,

Please read this FAQ: https://wpdiscuz.com/community/f-a-q/how-to-disable-nicenames-2/

There is not necessary to use the CSS code. You can hide the nice name using the according option.  

paulcola
(@paulcola)
Joined: 1 year ago

Active Member
Posts: 5

@asti Ah, makes sense! Great. I don't use mentioning anyway so this is a much cleaner solution. 

Thanks so much! I've removed the CSS (a good temp workaround for sure) and turned off mentioning. Tested, works great.

Share: