wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

Not showing likes properly anymore


danniee
Posts: 27
Topic starter
(@danniee)
Eminent Member
Joined: 11 months ago

Hi,

I've just noticed that likes are not displayed properly anymore. The number of likes are ok, but it shows the like button as "grey" and not "green" when I have liked a comment. This has never happened before and I've used this plugin for a very long time. I suspect it could be any of the recent updates because I haven't done anything to the site.

Also, if a user who has already liked, likes the comment again (which is possible since it shows the comment us not liked yet) it removes 1 like instead of warning that the user has already like the comment.

It appears to me that it's not working properly with the cache plugin anymore because it's behaving exactly like that. I have of course tried clearing cache.

Is it possible for me to rollback to some older version of this plugin?

10 Replies
danniee
Posts: 27
Topic starter
(@danniee)
Eminent Member
Joined: 11 months ago

I've tried deactivating the cache plugin but the problem persists. Very strange.

Reply
danniee
Posts: 27
Topic starter
(@danniee)
Eminent Member
Joined: 11 months ago

Disabling "Comments and Users Cache" in the settings seems to have helped. I've always had this enabled in the past without any issues. I assume it's not optimal having to leave this disabled.

Reply
danniee
Posts: 27
Topic starter
(@danniee)
Eminent Member
Joined: 11 months ago

I assume it was activated all the time because I haven't made any changes to the settings in ages. Did the recent update maybe enable it?

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

We're going to check the issue. I'll update this topic once I get some news for you.

Reply
danniee
Posts: 27
Topic starter
(@danniee)
Eminent Member
Joined: 11 months ago

Ok, thank you.

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

@danniee,

We don't find such an issue on our test websites. Could you please create a dev/staging copy of your website in some sub-domain, make sure the problem exists and send admin details to us? You can use Duplicator to create that site.

Reply
danniee
Posts: 27
Topic starter
(@danniee)
Eminent Member
Joined: 11 months ago

Hi, honestly that feels like too much of a hassle for me to do. I'm afraid to mess things up since it's a very big and important website. For now I have deactivated cache in the plugin settings so now it works. Doesn't seem optimal but you it is what it is. Thanks.

Reply
3 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

@danniee,

If you provide us admin login details, we'll check it and try to find a solution. As I've already mentioned, we've checked many times and don't find such an issue on our test websites. 

 

Reply
danniee
(@danniee)
Joined: 11 months ago

Eminent Member
Posts: 27

@asti I didn't mean to sound arrogant, it's just that I don't have too much time to invest in these kinds of things and don't want to risk messing anything up. Is the cache thing ON by default or? Like I said, I'm not sure if it was always on or not, or if it was turned on automatically after the recent update. I don't really notice a significant change in performance after I turned it off.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3337

No problem you can just keep the option disabled if it solves the issue. By default, it's enabled. However, if you once disable the option it'll keep that value.  

Reply
Share: