wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Lazy Loading of Comments Not Working in Mobile

7 Posts
3 Users
0 Likes
216 Views
jamigold
Posts: 8
Topic starter
(@jamigold)
Active Member
Joined: 4 months ago

Hi,

I was hoping to use the "Lazy load comments on scrolling" option in the Comment Thread Displaying setting screen on my site.

However, during testing, I noticed that this functionality doesn't seem to work in mobile mode (including tablet). Is this expected behavior? Or am I missing something?

In the desktop mode, the next batch of comments load properly on scroll (the comment by Jason Wrench is the last comment of the first batch):

Screenshot of Successful Lazy Load in Desktop Mode

In mobile mode for tablet and phone (where the sidebar wraps below the post content/comment section), the next batch never loads on scroll:

Screenshot of Failed Lazy Load in Tablet Mode
Screenshot of Failed Lazy Load of more Comments in Mobile Mode

The layout properly recognizes that there should be more comments. If I switch to the "Load More button" option in the Comment Thread Displaying setting, the button will show up in mobile mode and the comments will properly load after the button is clicked:

Screenshot of Correct Load More Button in Mobile Mode
Screenshot of Correct Loading of Comments after Button Push in Mobile Mode

Any thoughts or suggestions? (The URL entered in the Website URL field here is a post with enough comments to trigger the behavior indicated.)

Thanks!
Jami

Topic Tags
6 Replies
Asti
Posts: 5037
 Asti
Support
(@asti)
Illustrious Member
Joined: 5 years ago

Hello Jami,

We're going to check this. Please wait a bit. I'll update this topic very soon. 

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5037

The issue will be fixed in the next version of the wpDiscuz plugin. 

jamigold
Posts: 8
Topic starter
(@jamigold)
Active Member
Joined: 4 months ago

Great! Thank you for the update! 😀

Jami

Jave
Posts: 13
 Jave
(@jave)
Eminent Member
Joined: 4 months ago

facing the same problem has this been fixed?

Jave
Posts: 13
 Jave
(@jave)
Eminent Member
Joined: 4 months ago

Edit: Issue only happens when using the ads extension and displaying ads inbetween the threads (like after every second or third an ad) - can you take a look into this as well? I'm displaying adsense display ads inbetween. 

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5037

@jave,

Please open your own support topic and leave an example URL to allow us to check the issue. 

Share: