Commenting Not Work...
 
Share:
Notifications
Clear all

Commenting Not Working.. WC Invalid Field

12 Posts
4 Users
1 Likes
2,208 Views
Posts: 4
Topic starter
(@usman)
Active Member
Joined: 4 years ago

Hello, i have been using wpDiscuz plugin for almost a year without any problems experienced whatsoever..  now since yesterday i noticed that visitors are no longer commenting on the site. when i try to post comments this is the error its giving:

{"code":"wc_invalid_field"}

although there is no error in the wp dashboard.. everything is ok... this seems to be appearing after the latest update..

prompt help will be appreciated,

thank you

11 Replies
Tom
Posts: 494
 Tom
Support
(@tomson)
Honorable Member
Joined: 8 years ago

Hi @usman,

Please list all plugins you're currently using.

In the meantime disable all security and antispam plugins and test it.

Reply
10 Replies
(@usman)
Joined: 4 years ago

Active Member
Posts: 4

@tomson

no new plugin has been installed.. the plugins were working flawlessly with wpDiscuz for like a year.. the problem persists after disabling the anti-spam plugins. perhaps the issue appears after the recent upgrade to 7.0.3

disx
Reply
Tom
 Tom
Support
(@tomson)
Joined: 8 years ago

Honorable Member
Posts: 494

@usman,

Please go to the WPBruiser plugin settings and disable it for comments. Then delete all caches and test it again.

Reply
(@usman)
Joined: 4 years ago

Active Member
Posts: 4

@tomson done... it was WpBruiser.. disabling comment protection solved the issue... but both WpDiscuz and WpBruiser have been working together for quite some time (almost a year) only since last couple of days the problems were raised.

however Bruiser effectively block spam comments so perhaps we will be needing an alternate for that.

Thank you

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6975

Hi @usman,

Could you please send the admin login details to info[at]gvectors.com email address? I'll ask the developers to check the issue for you. 

Reply
 LMM
(@lmm)
Joined: 4 years ago

New Member
Posts: 3

@usman I have the exact same problem and it goes away after disabling wp bruiser. However wpbrusier is a good plugin and I'd like to keep both around.

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6975

@lmm,

Please navigate to Dashboard > WPBruiser > WordPress tab, find and uncheck the "Protect Comments Form" option. 

Then delete all caches and check again. Please don't forget to press CTRL+F5 (twice) on the frontend before checking. 

Reply
 LMM
(@lmm)
Joined: 4 years ago

New Member
Posts: 3

@asti Yes that works. But I WANT to use wpbruiser to protect my comments. I should be able to use both like I was doing before.

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6975

@lmm,

You can use the wpDiscuz built-in Google reCAPTCHA to enable the comment protection. More info here: 

https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/google-recaptcha/

Reply
 LMM
(@lmm)
Joined: 4 years ago

New Member
Posts: 3

@asti I get you but that's just a workaround and increases my page size. Can this not be fixed like it was before?

Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6975

@lmm,

Yes, it'll be fixed in the next update (no ETA). 

Reply
Share: