wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Comment form not showing up - some sort of interaction with WP Rocket caching

6 Posts
2 Users
0 Likes
480 Views
eschlange
Posts: 4
Topic starter
(@eschlange)
New Member
Joined: 2 years ago

Hi Folks,

In the past few weeks, I've noticed an issue on my site that is preventing people from commenting. The comment field on posts is showing like what I've attached - just a blank gravatar, no comment field:

cache 1

But then, if I click WP Rocket's "purge this URL" option, I get the second attachment - which shows the comment field.

cache 2

I haven't changed any WP Rocket settings. Any idea what could be causing this? It's a big issue for me, as it's preventing people from commenting on the site!

The above screenshots were taken from this page: https://zwiftinsider.com/get-an-edge/

5 Replies
eschlange
Posts: 4
Topic starter
(@eschlange)
New Member
Joined: 2 years ago

Update on this - I disabled WP Rocket and the issue was still happening, so I dug a little more and discovered that when I purge the URL from my Nginx cache, that's what fixes it. So the problem is in the Nginx caching, not WP Rocket.

eschlange
Posts: 4
Topic starter
(@eschlange)
New Member
Joined: 2 years ago

Digging still further, I'm seeing the issue even with all caching plugins turned off.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5037

@eschlange,

Please navigate to Dashboard > wpDiscuz > Settings > General Settings tab, disable the following two options:

  • minify JS and CSS Files to Optimize Page Loading Speed
  • combine JS and CSS Files to Optimize Page Loading Speed

Then, delete all caches, and let us know. 

eschlange
Posts: 4
Topic starter
(@eschlange)
New Member
Joined: 2 years ago

I think this has fixed it... awesome! I'll reply here if I see the issue again.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5037

@eschlange,

We still see some js errors on your website. Please properly delete all caches reset all minification files and check the console to see if the issue is solved or not. 

Watch this video: https://www.screencast.com/t/XU3FUKzICRQz

Share: