wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

Comment and Rating Not Showing


jbowyer
Posts: 4
Topic starter
(@jbowyer)
New Member
Joined: 7 months ago

When my site is opened (which defaults to the current post) neither the comments nor the rating sections are shown. However, if the user uses the side menu to select a post to read (even the current post) or a prior comment or open another page, the page refreshes and both the comment and rating sections are now visible. A refresh from the top of the browser will not bring the comments out.

I have deactivated all other plugins, deleted all caches, tried 4 different browsers and am still stuck. Any suggestions why I can't get comments & ratings when the site is first pulled up?

9 Replies
Asti
Posts: 3556
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

@jbowyer,

Could you please leave some example URL? 

Reply
4 Replies
jbowyer
(@jbowyer)
Joined: 7 months ago

New Member
Posts: 4

Thanks for your reply - I really appreciate your assistance.

However, the video does not start when the site first loaded. In order to get to the home page, you had to select it from the top menu. This WILL generate both the comment and rating sections. The issue is that when the site first opens at the latest post - before any other page is opened - the sections do NOT show. If I were a user and opened the site by going to jbowyer.com, I would not see the sections and would not know that I had to go to another page to see them. 

I believe that I must have some setting wrong - either in your plugin or the general WordPress setup - that generates this bizarre behavior but haven't been able to find the wrong setting.

 

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3556

@jbowyer,

Do I understand you correctly that the wpDiscuz is missing on the home page? If so, please attentively read this doc: https://wpdiscuz.com/docs/wpdiscuz-7/plugin-settings/general-settings/#enable-wpdiscuz-on-home-page

Reply
jbowyer
(@jbowyer)
Joined: 7 months ago

New Member
Posts: 4

No - that is not what I am saying. The problem is that when the site is first opened - whatever page it is opened to - the comment section does not appear. If the user then selects another page or post, the comment section does appear. I want the user to see the comment section as soon as the page is opened, which happens to be the last post.

Please visit the site at jbowyer.com. Do not select anything, and you will see that neither the comments nor the rating sections appear - no matter how long you wait.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3556

@jbowyer,

The jbowyer.com this is a home page of your website, the comment section is not supported there. There is a list of posts on your home page, so wpDiscuz is not showing there. On the other pages/posts it works fine. 

Reply
jbowyer
Posts: 4
Topic starter
(@jbowyer)
New Member
Joined: 7 months ago

The site is jbowyer.com - thanks for youe help

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3556

@jbowyer,

Please watch this video: https://www.screencast.com/t/8rJUAxasrdAi

Reply
Amber247
Posts: 4
(@amber247)
New Member
Joined: 6 months ago

I am having the same issue. The "leave a comment" icon doesn't pop up anymore.

Reply
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3556

@amber247,

Please open your separate support topic and try to explain using some screenshot the issue you have. It'd be better if you also leave some example URL to allow us to better understand the issue. 

Reply
Share: