wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] You are not allowed to vote for this comment


lmmuk
Posts: 7
Topic starter
(@lmmuk)
Active Member
Joined: 1 year ago

@asti I have exactly the same issue on my blog here: https://www.lastminutemusicians.com/blog/reddit-for-musicians/#comments

When you try to vote as a guest (with guest voting enabled) you see an error message - see screenshot.

IMG 2392

Thanks in advance!

Topic Tags
13 Replies
Asti
Posts: 3943
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

Hi @lmmuk,

We see some js errors on your website. The issue may come from the cache plugin, you're using. Please try to deactivate the cache plugin and check again. 

WpdEditor is not defined
9 Replies
lmmuk
(@lmmuk)
Joined: 1 year ago

Active Member
Posts: 7

@asti Thanks for your reply. I've tested this idea but unfortunately de-activating the cache plugin made no difference to the problem.

Also I'm not seeing the JS error you screenshotted -> perhaps this went away when I purged the cache.

Any other ideas?

Many thanks.

lmmuk
(@lmmuk)
Joined: 1 year ago

Active Member
Posts: 7

By the way I just noticed a response header from the post request that happens when I try to vote as a guest that may be a clue:

success: false

data: wc_deny_voting_from_same_ip

Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3943

@lmmuk,

If you're sure that the "Allow Guests to Vote for Comments" option is enabled, then there is some other plugin, that causes the issue.

Please deactivate the plugins one by one and check after each deactivation to find a problem maker. 

lmmuk
(@lmmuk)
Joined: 1 year ago

Active Member
Posts: 7

@asti unfortunately this issue persists with all plugins disabled (apart from yours!)

Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3943

@lmmuk,

Could you please send the admin login details to allow us to check the issue? 

lmmuk
(@lmmuk)
Joined: 1 year ago

Active Member
Posts: 7

@asti where do I send the admin details to?

Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3943

@lmmuk,

You should send it to info[at]gvectors.com email address. 

lmmuk
(@lmmuk)
Joined: 1 year ago

Active Member
Posts: 7

@asti I have emailed the details - look forward to hearing from you, thanks! 🙂

Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3943

@lmmuk,

For some reason, all the guest have the same IP address, thus they are not allowed to vote for the comment. wpDiscuz logs IP Addresses as well.

If all none of the plugins caused the issue, then you should contact the hosting support and ask them to check the configurations. Please let them know that all guests have the same IP address, they'll fix the issue. 

AeroStar
Posts: 84
(@aerostar)
Trusted Member
Joined: 2 years ago

@Immuk,

If you're voting as a guest under your same IP (for testing purposes), the above error message is correct. Your troubleshooting message: "data: wc_deny_voting_from_same_ip" confirms that.

You will have to use another IP to test your configuration.

Cheers!

lmmuk
Posts: 7
Topic starter
(@lmmuk)
Active Member
Joined: 1 year ago

Hi, it turns out as our server is behind a Proxy I had to add some extra setup lines to the wp-config file to make sure the remote IP address was correct. 

Thanks for your help with this.

 

Just in case it helps others, this is what I added:

// Use X-Forwarded-For HTTP Header to Get Visitor's Real IP Address 
if ( isset( $_SERVER['HTTP_X_FORWARDED_FOR'] ) ) {
$http_x_headers = explode( ',', $_SERVER['HTTP_X_FORWARDED_FOR'] );

$_SERVER['REMOTE_ADDR'] = $http_x_headers[0];
}
techtrader
Posts: 5
(@techtrader)
Active Member
Joined: 2 months ago

Im having same issue, when I try new PC, new location, different IP I get same error.
Im using Sucuri.net will a firewall or CDN networj.

 

I just tried your WP-CONFIG file fix and it worked! wow thanks a bunch!!

Share: