wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

Nonce is invalid since last update

Page 1 / 2

camperhelp
Posts: 18
Topic starter
(@camperhelp)
Active Member
Joined: 1 year ago

Hello Asti,

i have since update 7.3.4 an error for all users on my forum https://camper.help.

If I use my admin user no issue or error is there.

"Nonce is invalid."

Could you please help.

Thank you

Kind regards

Florian

 

30 Replies
camperhelp
Posts: 18
Topic starter
(@camperhelp)
Active Member
Joined: 1 year ago

Delete the cache in WProcket was not successful. Fallback to 7.3.3 works as previous discussed in other post is working is interims solutions and 7.3.3. is now active on my page. Maybe you have please an idea for this, or new updated version.

Reply
6 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@camperhelp,

Please follow the steps below:

  1. deactivate the cache plugin,
  2. update wpDiscuz plugin,
  3. re-activate your cache plugin, 
  4. delete all caches (website, wpDiscuz, browser) and purge CDN / CSS /JS minifications
Reply
jrr
 jrr
(@jrr)
Joined: 1 month ago

New Member
Posts: 1

@asti   Hi - my commenters are having the same nonce invalid issue and I disabled the plug-in. Is the issue fixed? Should I try the steps above? Thanks!

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@jrr,

Should I try the steps above?

Sure, please try the steps above. Please press CTRL+F5 (twice) on the frontend before checking.

 

Reply
camperhelp
(@camperhelp)
Joined: 1 year ago

Active Member
Posts: 18

@asti 

Sorry, not working for me. Have done the following steps.

1. Deactivated WP-Rocket plugin
2. Updated from WPDiscuz from 7.3.3. to 7.3.4
3. Started WP-Rocket plugin
4. Deleted WP Rocket cache and purged WP Rocket CDN, deleted Browser cache and pressed "Purge Comment and User Caches" in general settings.

Works as Admin without issues, but normal User is getting "Nonce is invalid." again. I changed back to 7.3.3.

I dont want to publish screenshots, but I can email you these steps.

What could be the next idea?

Thank you for your help

Kind regards

Florian

 

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@camperhelp,

Please use the old version of the wpDiscuz plugin until we fix the issue. The next update will come soon.  

Reply
camperhelp
(@camperhelp)
Joined: 1 year ago

Active Member
Posts: 18

@asti
Works for me with 7.3.7 (maybe also 7.3.5, but didnt tested it). Thanks for your update. Best regards. Florian

Reply
Nosh Nourish
Posts: 1
(@nosh-nourish)
New Member
Joined: 1 month ago

Hello, I am having the same issue with the nonce is invalid error message.  How to do I go back to the previous version of the plugin until there is a new update?

Reply
1 Reply
Zoker
(@zoker)
Joined: 4 months ago

Eminent Member
Posts: 20
Zoker
Posts: 20
(@zoker)
Eminent Member
Joined: 4 months ago

Same issue for me with version 7.3.5

Edit: The file

/wp-content/plugins/wpdiscuz/utils/ajax/wpdiscuz-ajax.php

 returns a 403 and I think that is causing the issue

Reply
wpdiscuz0
Posts: 9
(@wpdiscuz0)
Active Member
Joined: 1 month ago

I believe I'm having the same issue as well. The plugin is suddenly causing a fatal error on my website, and no one can comment or vote for comments. 

Reply
2 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@wpdiscuz0,

The issue with WP Nonce should be fixed in the just-released 7.3.5 version. Please update, delete all caches, purge CDN if you have, press Ctrl+F5 on the website front-end to reset the browser cache and check it during and after the 24 hours.

Reply
wpdiscuz0
(@wpdiscuz0)
Joined: 1 month ago

Active Member
Posts: 9

@asti Will purging the vote and comment cache get rid of the comments and votes on old posts?

Reply
solarian
Posts: 8
(@solarian)
Active Member
Joined: 1 month ago

For me, the issue didn't arise in 7.3.4 but has been introduced in 7.3.5. Still needs work, I'm afraid.

Reply
8 Replies
wpdiscuz0
(@wpdiscuz0)
Joined: 1 month ago

Active Member
Posts: 9

@solarian @asti Yes sorry that's what I meant too, I am in 7.3.5 and am still having the issue. It's the first time I've ever had issues with the program and it's affecting my visitors.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@wpdiscuz0

Please update, delete all caches, purge CDN if you have, press Ctrl+F5 on the website front-end to reset the browser cache and check it during and after the 24 hours.

Please make sure these steps are done and eave some example URL to allow us to check it. 

Reply
wpdiscuz0
(@wpdiscuz0)
Joined: 1 month ago

Active Member
Posts: 9

@asti Will purging the vote and comment cache get rid of the comments and votes on old posts? Is that the cache you're telling me to delete?

 

 
 
Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@wpdiscuz0,

You need to delete the cache and purge CDN / CSS /JS modifications of your website within the cache plugin you're using,  then delete "Purge Comment and User Caches" in the wpDiscuz plugin settings. 

After these steps delete the browser caches (twice CTRL+F5 on the frontend) as well and check again. 

Reply
solarian
(@solarian)
Joined: 1 month ago

Active Member
Posts: 8

@asti 

I've done all those things on my dev site, still having the same issue. Rolling back to 7.3.3 or 7.3.4 fixes it.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@solarian,

Please provide us an example URL.  

Reply
solarian
(@solarian)
Joined: 1 month ago

Active Member
Posts: 8

@asti 

If you'll give me the perms to send you a private message I'll do so.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3860

@solarian,

Sure, please PM it to me.

Reply
Asti
Posts: 3860
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

Dear users,

The new version is ready! 

Please update the wpDiscuz to the latest version (v. 7.3.6), delete all kind of caches and check again.

Reply
3 Replies
Zoker
(@zoker)
Joined: 4 months ago

Eminent Member
Posts: 20

@asti For me the issue still exists (7.3.7) and I tried to delete cache, don't use a server side cache plugin (even tried incognito mode)

Reply
Tom
 Tom
Support
(@tomson)
Joined: 6 years ago

Support Team
Posts: 447

@zoker,

Try to switch on the "Use WordPress native AJAX functions" option in wpDiscuz > Settings > General Settings tab. Again, delete all caches and check it.

Reply
Zoker
(@zoker)
Joined: 4 months ago

Eminent Member
Posts: 20

@tomson Works 🙂

Reply
Page 1 / 2
Share: