wpDiscuz - WordPress Comment Plugin
Comment Moderation
 
Share:
Notifications
Clear all

Comment Moderation


Mslaporte
Posts: 8
Topic starter
(@mslaporte)
Active Member
Joined: 5 months ago

Currently allowing users to login with Google for commenting. 

Comments are not being held for moderation, nor is an email being sent to alert for new comments. 

Please help! 

14 Replies
Asti
Posts: 4864
 Asti
Support
(@asti)
Support member
Joined: 5 years ago

Hi

Are you sure the  "Comment must be manually approved" checkbox is checked in the "Before a comment appears" section? It's located in the Dashboard > Settings > Discussion admin page. 

Reply
Mslaporte
Posts: 8
Topic starter
(@mslaporte)
Active Member
Joined: 5 months ago

Absolutely. It's checked. 

Reply
7 Replies
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4864

@mslaporte,

You have a major issue with your website. You've wrong configured the new user default role option.

Please navigate to Dashboard > Settings > General admin page and change the value of the "New User Default Role" option. 

image
Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4864

Don't forget to edit the users and change their user roles. 

Reply
Mslaporte
(@mslaporte)
Joined: 5 months ago

Active Member
Posts: 8

@asti Can you point me towards where I do that and what I need to change?

Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4864

@mslaporte,

The path is already provided in the post above However I've recorded the video: https://www.screencast.com/t/QJCZL76Xtw

The value of the "New User Default Role" option is already changed by me, however, you can also change it as you like. 

Reply
Mslaporte
(@mslaporte)
Joined: 5 months ago

Active Member
Posts: 8

@asti I'm currently looking at it and it's set as "subscriber"  - not "administrator.

Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4864

@mslaporte,

I've changed it. You can see it in the video. 

Reply
Mslaporte
(@mslaporte)
Joined: 5 months ago

Active Member
Posts: 8

That role has no permissions. 

Reply
Mslaporte
Posts: 8
Topic starter
(@mslaporte)
Active Member
Joined: 5 months ago

Oh wow. Thank you!

Reply
Asti
Posts: 4864
 Asti
Support
(@asti)
Support member
Joined: 5 years ago
Posted by: @asti

The path is already provided in the post above However I've recorded the video: https://www.screencast.com/t/QJCZL76Xtw

The value of the "New User Default Role" option is already changed by me, however, you can also change it as you like. 

Please read attentively my post

Reply
3 Replies
Mslaporte
(@mslaporte)
Joined: 5 months ago

Active Member
Posts: 8

@asti Thank you so much!

Reply
Mslaporte
(@mslaporte)
Joined: 5 months ago

Active Member
Posts: 8

@asti by using the Google login, is it always going to add them as a role on the site? I'd just like them to be able to use it as a verification tool, not necessarily as a way to be added as a user of any kind.

Reply
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4864

@mslaporte,

by using the Google login, is it always going to add them as a role on the site? 

Sure it's registration by social network. 

 I'd just like them to be able to use it as a verification tool, not necessarily as a way to be added as a user of any kind.

I'm really sorry, but there is no way to separate the social network registration from the general one.

Reply
Share: