Can't Login with li...
 
Share:
Notifications
Clear all

Can't Login with linkedin  


emanuelxpt
Posts: 3
(@emanuelxpt)
New Member
Joined: 1 month ago

Hi,

I'm using the last version of the plugin, I followed the guide to connect the Linkedin login, but the callback URL returns me a 301, so I can't do the login with Linkedin.

 

can't someone help me with this issue?

 

Thanks

9 Replies
Asti
Posts: 819
 Asti
Support
(@asti)
Support member
Joined: 3 years ago

Hi @emanuelxpt,

Please provide us some example URL to allow us to check the issue. 

Reply
7 Replies
aerosboss
(@aerosboss)
Joined: 1 month ago

New Member
Posts: 4

@asti I have a similar problem with login Linked. After I put my linkedin password and accept the permission the result is:

404 Not Found.
The requested URL /wpdiscuz_auth/linkedin/ was not found on this server.

Reply
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 819

@aerosboss,

Please leave some example URL top to allow us to check the issue. 

Reply
aerosboss
(@aerosboss)
Joined: 1 month ago

New Member
Posts: 4

@asti In Linkedin Auth setting I set the Authorized redirect URL: https://exampledomain.com/wpdiscuz_auth/linkedin/

The example URL in the browser page where "404 Not Found" is shown, is:

https://exampledomain.com/wpdiscuz_auth/linkedin/?code={codeformat}&state={codestate}

Thank you for your help

Reply
aerosboss
(@aerosboss)
Joined: 1 month ago

New Member
Posts: 4

@asti, I configured twitter with the login product with the required data and the Callback URL, I put in WpDiscuz the API Key and API Secret. However, when I test the login with Twitter to make a comment it shows me the error:

No profile data is returned from application. Please contact your administrator.

The URL where this message is shown is: https://mydomain.com/wp-admin/admin-ajax.php?action=wpd_login_callback&provider=twitter&oauth_token={codetoken}&oauth_verifier={code}

 😞 I really don't know what to do to be able to log in with LinkedIn and Twitter, I would appreciate any help

Reply
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 819

@aerosboss,

There is not such an issue on our test website. Please leave your website URL to allow us to check the issue and help you to understand the reason for the issue. 

Reply
aerosboss
(@aerosboss)
Joined: 1 month ago

New Member
Posts: 4
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 819

@aerosboss,

Please navigate to Dashboard > Settings > General admin page, make sure the URLs in the Site Address (URL) and WordPress Address (URL) fields are matched. 

2020 07 03 13 57 37

Please see the screenshot below there is an index.php after the domain name. 

2020 07 03 14 37 45

Also, you should correct The Valid OAuth Redirect URIs.

You can be found in the Dashboard > wpDiscuz > Settings > Social Login and Share admin page (LinkedIn section).

You should add index.php after the domain name in The Valid OAuth Redirect URIs.

https://example.com/ index.php/wpdiscuz_auth/linkedin/

Reply
emanuelxpt
Posts: 3
(@emanuelxpt)
New Member
Joined: 1 month ago

Hi @asti

Stay here the url, him returns with Status Code: 303 
 https://www.linkedin.com/oauth/v2/authorization?client_id={client_id}&redirect_uri=https%3A%2F%2Fwww.sample-domain.com%2Fblog%2Fwpdiscuz_auth%2Flinkedin%2F&response_type=code&scope=r_liteprofile%20r_emailaddress&state={state_code} 

The URL for wpdiscuz with Status Code: 302

 https://www.sample-domain.com/blog/wpdiscuz_auth/linkedin/?error=unauthorized_scope_error&error_description=Scope+%26quot%3Br_liteprofile%26quot%3B+is+not+authorized+for+your+application&state={state_code} 

Thanks

Reply
Share: