The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
amp nofollow proble...
 
Share:
Notifications
Clear all

[Solved] amp nofollow problem

22 Posts
2 Users
1 Reactions
1,323 Views
Posts: 18
Topic starter
(@aga2442)
Eminent Member
Joined: 2 years ago

hello,

Ampforwp and rankmath plugins are active on my website.

before sending you this problem, ampforwp developers have studied this problem in detail. and they told me to share it with you.

"nofollow" is active for "authors" pages on my website via rankmath plugin.

The reason for this: because there are too many users on my website, I prevent search engines from indexing.

but after doing this situation, an error appeared in a very different area.

On the semrush seo analysis website, I started getting this error constantly:

1,877 outgoing internal links contain nofollow attribute...

On the semrush website, amp pages and non-amp versions of these pages appear in the details area of this error.

I also forwarded this error to them because I thought it would be from the ampforwp plugin.

After doing the necessary checks many times on them, they sent the following message:

We complete the debugging process, and the wpDiscuz plugin adds the nofollow attribute to the author name and exit text. Our plugin does not add any nofollow attributes; it just reflects the non-AMP nofollow attribute on AMP.
 
You can see the referencec screenshot

In summary: In all posts and amp posts where the wpdiscuz plugin is active, there is a very serious error in the (author link page) seo field.

Attached are images on the subject.

If you want I can share all the necessary details.

 

sample post:

kobivadisi . com/10-bin-saat-kurali/amp/

kobivadisi . com/10-bin-saat-kurali/

 

ss1
ss1 (1)
21 Replies
Asti
Posts: 7229
 Asti
Support
(@asti)
Illustrious Member
Joined: 7 years ago

Hi aga2442,

The wpDiscuz adds the nofollow only in the following two cases:

1. When the user adds the image URL and it's turned to the <img> tag in the comment content after the comment is added. The option is called "Image Source URL to Image Conversion". It's located in the Dashboard > wpDiscuz > Settings > Comment Content and Media admin page.

2. If the "Use Website URL as Profile URL" option is enabled. This option can be found in the Dashboard > wpDiscuz > Settings > User Authorization and Profile Data admin page. 

You can use the hook code below and make the changes you like: https://wpdiscuz.com/docs/codex/filters/wpdiscuz_author_link_attributes/

Posts: 18
Topic starter
(@aga2442)
Eminent Member
Joined: 2 years ago

@asti thanks.

The settings you mentioned are as in the images.

I also want to emphasize this.

The problem I mentioned does not occur before login.

but nofollow problem occurs after user login.

If I add the code on this page, will the problem be fixed?
if it will fix the problem where should i add the code?

ssho
ssho2
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

@aga2442,

Use this code: 

add_filter("wpdiscuz_author_link_attributes", function ($attrs) {
   if (isset($attrs["rel"]) && $attrs["rel"] === "nofollow") {
      unset($attrs["rel"]);
   }
   return $attrs;
});

The code should be put in the active theme functions.php file. 

This article should be helpful for you: https://www.wpbeginner.com/plugins/how-to-easily-add-custom-code-in-wordpress-without-breaking-your-site/

Posts: 18
Topic starter
(@aga2442)
Eminent Member
Joined: 2 years ago

@asti

I'm doing what you said. but still nofollow continues to appear.

You can also see the video.

In the other browser I tested, the member is logged in.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

@aga2442,

Please delete all kinds of caches (website, wpDiscuz, browser before checking). 

Posts: 18
Topic starter
(@aga2442)
Eminent Member
Joined: 2 years ago

@asti

While the member login is active, the cache is disabled. I also tested this by logging in as admin.

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

@aga2442,

What about the wpDiscuz cache? Have you deleted it?  

Posts: 18
Topic starter
(@aga2442)
Eminent Member
Joined: 2 years ago

@asti

found on the general settings page; I also tried clearing the cache.

cache
2 Replies
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

@aga2442,

Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check the issue for you. 

Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

We're not able to access to your website dashboard. Please check the login details. 

Posts: 18
Topic starter
(@aga2442)
Eminent Member
Joined: 2 years ago

@asti

I emailed the information again yesterday.

2 Replies
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

ok, we'll check and let you know asap.  

Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7229

@aga2442,

The nofollow attribute in the please you're mentioning doesn't come from the wpDiscuz plugin. 

wpDiscuz adds the nofollow attribute in the two places I've mentioned here: https://wpdiscuz.com/community/postid/19090/ And the hook-code provided by us removes them. 

Probably the attribute is being added by another plugin.

Anyway you can use the solution provided here: https://www.serpbabel.com/how-to-fix-internal-nofollow-links-in-wordpress-for-beginners-with-pictures/

It should remove the attribute. 

Page 1 / 2
Share: