The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
Social Media Redire...
 
Share:
Notifications
Clear all

Issue [Solved] Social Media Redirect URI is incorrectly formatted

2 Posts
2 Users
0 Reactions
371 Views
Posts: 1
Topic starter
(@psdcovers)
New Member
Joined: 1 year ago

Our site resides on Amazon Cloudfront which is an AWS caching service.  To work on our site we use our staging site which gets cached automatically by W3TC which is then pulled by Cloudfront and served worldwide. Because every page is cached it means minimum to no strain on the wp database for most operations etc.

However, in order to allow us to work alongside W3TC and AWS we have our staging url set in the wordpress Settings > General as http://content.psdcovers.com

W3TC dynamically swaps out http://content for https://www for all our cached and live search queries.

The problem we are having with wpDiscuz is that it seems to hardcode the Wordpress globals for the site address into all requests.

We cannot modify the Settings > General > Site or Wordpress url settings without causing W3TC or AWS to fail.  They must remain as-is.

The Problem:

wpDiscuz sends Google, Facebook, Twitter etc a redirect_uri which is formatted as http://content.psdcovers.com https://www.psdcovers.com

So the question is the following:

Without modifying the wpDiscuz plugin directly, what is the most practical method or function that we can use/add to get wpDiscuz to append the correct site url to the redirect_uri variable?  as stated above, we work from a staging server that automatically pushes cached content to www.  We cannot modify our Settings > General to use anything other than content.psdcovers.com.

Thanks.

 

1 Reply
Asti
Posts: 7240
 Asti
Support
(@asti)
Illustrious Member
Joined: 7 years ago

There is used the admin_url function to generate the redirect_uri. We cannot help you as we don't know how you've done the configurations.

Just note: we don't do hardcode. As a small tip: you can use the admin_url filter to change the redirect_uri if it's necessary.

Share: