wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Votes suddenly not displaying


Sophie
Posts: 26
Topic starter
(@sophie)
Eminent Member
Joined: 2 years ago

So about a week ago the numbers of up and down votes in comments stopped displaying.

The votes are still being talleyed in the database and initially the counter registers the comment,-  but when the page refreshes the counter returns to zero even though the vote is still recognized.

So we currently have all our comments showing zero votes even though they have been voted on many times. 

what is causing this? 

19 Replies
Asti
Posts: 4894
 Asti
Support
(@asti)
Support member
Joined: 5 years ago

Hi Sophie,

Please leave an example URL to allow us to check the issue. 

1 Reply
Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti I left the URL yesterday

Sophie
Posts: 26
Topic starter
(@sophie)
Eminent Member
Joined: 2 years ago
16 Replies
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

ok, we see the issue.

Please wait a bit. We'll check and get back to you asap. 

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

Please navigate to Dashboard > wpDiscuz > Settings > General Settings, disable the wpDiscuz cache option and check again. 

Don't forget to delete other plugin caches before checking. 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti Thanks. We did that. We also disabled some other plugins. Problem still there.

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

@sophie,

Navigate to Dashboard > wpDiscuz > Settings > General Settings tab, enable the "Use WordPress native AJAX functions" option and check again. 

If it doesn't help export the wpDiscuz options from the Dashboard > wpDiscuz > Tools > Backup Options and send them to us.

image

We'll try to check with your configurations. 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti it didn't work - where shall I send the file?

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

@sophie,

You can either attach it here or send it to the info[at]gvectors.com email address. 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti

 

here you go - hope it gets us somewhere! 

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

@sophie,

Please confirm that this option is checked by you: 

Navigate to Dashboard > wpDiscuz > Settings > General Settings tab, enable the "Use WordPress native AJAX functions" option and check again. 

We see that it's disabled in the options you've sent us. 

We don't see the issue with the settings you've sent us. Please let us know if you have any cache plugins or server-side cache. 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti we did check it and then flushed the caches etc but it made no difference, so we unchecked it again. 

I will check with our server manager about the other cache questions and get back 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti we use cloudflare & W3 Total Cache

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

@sophie,

Please deactivate all kinds of caches and check again. 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti we did. It did not fix the problem

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

@sophie,

Downgrade the wpDiscuz, check and let us know how it works. 

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti What is the best/easiest way to do that?

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Support member
Posts: 4894

This article should be helpful for you: https://increasily.com/how-to-downgrade-a-wordpress-plugin/

Sophie
(@sophie)
Joined: 2 years ago

Eminent Member
Posts: 26

@asti we finally fixed it. It was a corrupt table in the database.

Share: