wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Nonce is invalid when Admin Tries to Comment

6 Posts
4 Users
2 Likes
362 Views
realrawnews
Posts: 1
Topic starter
(@realrawnews)
New Member
Joined: 6 months ago

Hello, 

I am the administrator of my website.

Suddenly, I'm receiving an error when I try to comment. This same issue does not seem to be effecting my users.

When I try to comment, an error appears on the upper-right corner of my window, "

Nonce is invalid"

 

I'm using the latest update of WPDiscuz.

I disabled all additional Discuz addons.

I cleared my browser cache and flushed my website cache.

But the error persists.

Any help appreciated. Thank you.

Topic Tags
5 Replies
Mark
Posts: 8
 Mark
Support Registered
(@mark)
Active Member
Joined: 1 year ago

Hi @realrawnews,

We need admin credentials for the account which gets that error, we have tried with registered User and didn't get any error. Send the admin credentials to info[at]gvectors.com,

Mention this topic URL in the email, and let me know here that you have sent the email.

inchenaim
Posts: 16
(@inchenaim)
Active Member
Joined: 2 years ago

Hi, i have the exact same problem as this one

Do your problems solve right now @realrawnews?

Right now, I am just using version 7.3.3 because it is not triggering the "nonce invalid" error when commenting as admin.

Can you check mine too @mark?

3 Replies
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5091

@inchenaim

Please update the wpDiscuz to the latest version, delete all caches and check again. If it doesn't help open your own topic and provide the example URL to allow us to check the issue.

inchenaim
(@inchenaim)
Joined: 2 years ago

Active Member
Posts: 16

Hello @asti, I've managed to solve the issue.

The leading cause is Cloudflare's page rule was set to cache everything. 

So, if anyone uses Cloudflare page rule cache everything, just disable it and use Cloudflare APO instead.

Now, I am able to use the latest WPDiscuz

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5091

@inchenaim,

Thank you for letting us know. Glad to hear that the issue is solved. 

We're going to mark this thread as resolved and close it. Feel free to open a new topic if you have further questions.

Share: