wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] issue with tags

12 Posts
2 Users
1 Likes
89 Views
Posts: 7
Topic starter
(@ljmyers)
Active Member
Joined: 2 weeks ago

I am having the same problem and do not know enough about php to follow the fix from just before this post. I did find post with the following code for css, but it produce what can be seen in the image I've included. Can someone please help?

image

#wpdcom ol li {
list-style-type: decimal !important;
}
#wpdcom ul li {
list-style-type: disc !important;
}

11 Replies
4 Replies
(@ljmyers)
Joined: 2 weeks ago

Active Member
Posts: 7

Once the comment from the image above was saved, this is the output. I am afraid that it will confuse future users though. It normally takes a day ot two for the comment to loose the list and begin to show all the the text strung together.

image
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5779

@ljmyers,

Please leave the URL where we can see the issue.Β 

(@ljmyers)
Joined: 2 weeks ago

Active Member
Posts: 7

@astiΒ 

url: https://recipeinprogress.com/recipe/a-not-quite-sugar-free-vanilla-wafer-banana-pudding/

The bulleted and numbered lists have maintained their format since adding the css code above. The only issue that remains is the double bulleting and numbering as shown in the image above the css code. This only occurs at the time of inputting the lists into the comment text area. As said before, it wouldn't be a problem except that it may confuse users. If we can fix it, wonderful! If not, it isn't the end of the world.

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5779

@ljmyers,

Please use the CSS code:Β 

#wpdcom .ql-editor ol li:before, #wpdcom  .ql-editor ul li:before  {
    display: none;
}
#wpdcom .ql-editor ol li, #wpdcom .ql-editor ul li{ 
   padding-left: 2px !important;
}

Put the code in the "Custom CSS code" textarea, located in the Dashboard > wpDiscuz > Settings > Styles & Colors admin page.

Don't forget to delete all kinds of caches before checking.

The video explains better the conflict: https://www.screencast.com/t/mxa8pTfBmJk

Posts: 7
Topic starter
(@ljmyers)
Active Member
Joined: 2 weeks ago

Seems to be working Asti. Thanks so much. πŸ™‚

6 Replies
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5779

@ljmyers,

We still see the issue. Please add this code as well.Β 

.ql-editor ol>li, .ql-editor ul>li {
    list-style-type: unset;
}
(@ljmyers)
Joined: 2 weeks ago

Active Member
Posts: 7
Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5779

@ljmyers,

Still doesn't work:Β  https://www.screencast.com/t/MzU9uOkfnIXh

Please try this code:Β 

#wpdcom .ql-editor ol>li, #wpdcom .ql-editor ul>li {list-style-type: unset !important;}
(@ljmyers)
Joined: 2 weeks ago

Active Member
Posts: 7

@asti Done...

Removed: 
.ql-editor ol>li, .ql-editor ul>li {
    list-style-type: unset;
}
Added:
#wpdcom .ql-editor ol>li, #wpdcom .ql-editor ul>li {list-style-type: unset !important;}

https://recipeinprogress.com/recipe/a-not-quite-sugar-free-vanilla-wafer-banana-pudding/

Asti
 Asti
Support
(@asti)
Joined: 5 years ago

Illustrious Member
Posts: 5779

@ljmyers,

Now everything is working fine: https://www.screencast.com/t/QzrnsMzF6

(@ljmyers)
Joined: 2 weeks ago

Active Member
Posts: 7

@asti I thought the same. Thank you so very much for sticking with it!

Share: