wpDiscuz - WordPress Comment Plugin
Share:
Notifications
Clear all

[Solved] Comment bubble doesn't appear


Visigoth
Posts: 11
Topic starter
(@visigoth)
Active Member
Joined: 11 months ago

My problem is similar - the comment bubble doesn't appear on pages on my staging site, but it does on posts. It does appear on pages on my live site and my development site though.  The wpDiscuz settings, the theme and plugins are the same.  The only difference seems to be the pages in the staging site are full width - OceanWP and stretched in Elementor. In all cases Pages have comments enabled, Setting>Discussion is set to allow people to comment, etc. 

Topic Tags
15 Replies
Asti
Posts: 3624
 Asti
Support
(@asti)
Support member
Joined: 4 years ago

@visigoth,

Please provide us some example URLs. 

Reply
Visigoth
Posts: 11
Topic starter
(@visigoth)
Active Member
Joined: 11 months ago

Asti, thanks for quick reply

On live site  https://youdrivehealth.com/laughter-2/ with bubble showing

On development site https://staging.youdrivehealth.com/laughter-2/ with bubble showing

In staging site https://staging1.youdrivehealth.com/laughter-2/ with no bubble

I can send temporary login if required, 

Reply
3 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@visigoth,

This is just a small CSS conflict, please watch the video below: 

https://www.screencast.com/t/DGZyJL0d

Use the CSS code below to solve the issue: 

div#wpd-bubble-wrapper {
display: block !important;
z-index: 111111111111 !important;
left: 25px !important;
}

Put the code in the Top Admin Bar > Customize > Additional CSS > "Additional CSS" textarea, save it, delete all caches and check again. 

Please don't forget to press Ctrl+F5 (twice) on the frontend before checking.

The red marked values can be changed as you like. 

Reply
Visigoth
(@visigoth)
Joined: 11 months ago

Active Member
Posts: 11

@asti

First of all, thanks for the detailed reply.  I watched the video and understood the point you were making. I added the code you sent via Appearance > Customise > Custom CSS/JS and put it near the top of the CSS and Published it. I then purged all the cache using SG Optimiser and Ctrl F5 twice at the front end. Still no bubble, although the rating shows at the bottom of the page. The Hubspot chat widget appears on the right.  

Any further thoughts?  I guess I've done something wrong.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@visigoth,

This is just a small CSS conflict, please watch the video below: 

https://www.screencast.com/t/DGZyJL0d

As you may see in the video this is just a CSS conflict. Please contact the SG Optimiser support and ask them how to properly delete the caches. 

Reply
Visigoth
Posts: 11
Topic starter
(@visigoth)
Active Member
Joined: 11 months ago

Hi Asti

I'm sure you're right about the cause of the problem.  However, purging the cache using SG Optimiser is incredibly simple - there's even a button called 'Purge SC cache' on the WP top admin bar! I also cleared the cache on 3 different browsers and still no bubble.  It could be I added the code you sent incorrectly or in the wrong place.

Sorry to be a pain - I really like the plugin and it's so frustrating to see it working perfectly in development and live but not on the site I want to send live soon! 

Thanks

Reply
7 Replies
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@visigoth,

Please send the admin login details to info[at]gvectors.com email address. I'll ask the developers to check the issue for you. 

Reply
Visigoth
(@visigoth)
Joined: 11 months ago

Active Member
Posts: 11

@asti

Thanks again for your help. I have sent an email to info@gvectors.com with a temporary login and I also copied the content of our conversation.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@visigoth,

The issue is fixed. We've jsut added the code in the "Custom CSS code" textarea, located in the Dashboard > wpDiscuz > Settings > Styles & Colors admin page. 

Reply
Visigoth
(@visigoth)
Joined: 11 months ago

Active Member
Posts: 11

@asti

Sorry - I replied to myself so I thought you might not see it. My comment was:

Even I have to laugh! I switched browsers and checked, and the comments bubble was there! Great! I was just off to leave a review, when I clicked the bubble. Nothing happened! It now appears on all the pages I've opened but nothing happens!

Reply
Visigoth
(@visigoth)
Joined: 11 months ago

Active Member
Posts: 11

@asti

Asti, please see comment below - the comment bubble appears but does nothing. On further investigation the problem only occurs on pages which use the Elementor Full Width template.

Reply
Visigoth
(@visigoth)
Joined: 11 months ago

Active Member
Posts: 11

@asti

Asti, thanks to your help I identified that the Elementor Full Width template was causing the problem so I switched all the offending pages using that template and found another way of making the pages full width, so I'm OK now. Thanks for your help.

Reply
Asti
 Asti
Support
(@asti)
Joined: 4 years ago

Support member
Posts: 3624

@visigoth,

Thank you for letting us know, glad to hear that the issue is solved. We also see a good review. Thank you very much! We really appreciate it. 

Reply
Visigoth
Posts: 11
Topic starter
(@visigoth)
Active Member
Joined: 11 months ago

That's fantastic, thanks. And thanks for explaining what you did. I must say I've never experienced support as good as this.  I'll certainly leave a five star review with Wordpress.

Reply
1 Reply
Visigoth
(@visigoth)
Joined: 11 months ago

Active Member
Posts: 11

Even I have to laugh! I switched browsers and checked, and the comments bubble was there! Great! I was just off to leave a review, when I clicked the bubble.  Nothing happened!  It now appears on all the pages I've opened but nothing happens!

Reply
Share: