The effects of alcohol on sustanon 250 leucine for – real weight loss & bodybuilding benefits?
Nonce is invalid in...
 
Share:
Notifications
Clear all

[Solved] Nonce is invalid in 7.6.4

34 Posts
18 Users
5 Reactions
1,862 Views
Eli
Posts: 53
 Eli
(@eli)
Trusted Member
Joined: 4 years ago

Unfortunately, I also had to downgrade to the previous version as it was impossible to edit comments and the comment's rating feature was not working either. 

It's not good having to do this, as we know the previous version has security issues. I hope they fix and correct this soon.

Reply
Posts: 11
(@tensionmouse)
Active Member
Joined: 3 years ago

Came here to say the same thing, nonce error since yesterday's 7.6.4 release. Rolled it back, all is well again.

Reply
Tom
Posts: 494
 Tom
Support
(@tomson)
Honorable Member
Joined: 9 years ago

We’re currently addressing this issue, which is mostly caused by your caching solutions. Cache plugins and server-side caching prevent comment forms from having dynamic “nonce keys” for security purposes. WordPress generates a unique key for each visitor, but caching solutions store it in the page HTML, resulting in the same “nonce key” for all visitors. This is a significant problem caused by cache plugins, and we’re actively working on a solution. Our plan is to resolve the issue and release a new version within the next 12-24 hours.

Reply
AAR
Posts: 15
 AAR
(@httpsallaboutromance-com)
Eminent Member
Joined: 4 years ago

Great! Thanks. 

Reply
Posts: 8
 jme
(@jme)
Active Member
Joined: 11 months ago

I can confirm this bug as well in 7.6.4.

Here's how I downgraded:

- Disable the wpdiscuz Plugin (only the main plugin, you don't need to disable the addons if you use any)

- Uninstall the wpdiscuz main Plugin

- Download the 7.6.3 version mentioned in this thread: https://wpdiscuz.com/community/plugin-update-issues/posting-comments-to-quickly/#post-21670

- This is a custom version of 7.6.3 which contains a fix for another problem in the original 7.6.3 version. See the thread for details.

- Install the zip via manual plugin upload (Plugins -> Install -> Plugin Upload at the top)

- Activate. Voila.

Reply
1 Reply
 jme
(@jme)
Joined: 11 months ago

Active Member
Posts: 8

PS: Remember to clear your cache if you use any caching plugins. And your browser cache as well.

Reply
Posts: 2
(@darkwolfcave)
New Member
Joined: 9 months ago

same issue here. With 7.6.3 without issue.
But really strange: if I click send again directly after the nonce error, the comment is saved and so is every other one in this browser.
Other browser, same game - send twice, then it works for this session.

Other point: after I deleted the "min" and "wp-rocket" folder in "cache", it worked until I recreated the cache with WPRocket...

Reply
2 Replies
Asti
 Asti
Support
(@asti)
Joined: 7 years ago

Illustrious Member
Posts: 7230

Dear users,

The new version is ready. The issue is fixed in the latest version of the wpDiscuz plugin. 

Please update the plugin, clean all kinds of caches and check again. 

Reply
(@darkwolfcave)
Joined: 9 months ago

New Member
Posts: 2

@asti I can confirm it works again for me. Thanks!

Reply
Posts: 11
(@cobourgjohn)
Active Member
Joined: 4 years ago

And 7.6.6 works for me too.  Thanks for the quick update.

Reply
Page 3 / 4
Share: