wpDiscuz - WordPress Comment Plugin
json GET issue led ...
 
Share:
Notifications
Clear all

json GET issue led to site shutdown - urgent


howardmart
Posts: 2
Topic starter
(@howardmart)
New Member
Joined: 6 months ago

I am getting the following line which is causing a spike in my CPU usage. I have disabled and deleted the Discuz plugin, but still have this line coming up. Is there any way to deal with it... my host (Siteground) is going to shut down my site if I don't fix it today.

115.189.80.105 www.rjworld.org - [31/Aug/2020:06:48:51 +0000] "GET /wp-json/wpdiscuz/v1/update?postId=4656&lastId=316&visibleCommentIds=194%2C228%2C316%2C HTTP/2.0" 403 98 "https://www.rjworld.org/speaker/charlotte-calkin/" "Mozilla/5.0 (Windows NT 10.0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.135 Safari/537.36" | TLSv1.3 | 0.318 0.339 0.339 BYPASS W NC:200000 UP:1

Topic Tags
5 Replies
Asti
Posts: 2144
 Asti
Support
(@asti)
Support member
Joined: 3 years ago

Hi @howardmart,

This issue comes from the Siteground cache system it has a hard cache, you should delete the caches and minified files. 

You can also activate the wpDiscuz plugin and disable the live update feature. 

Reply
howardmart
Posts: 2
Topic starter
(@howardmart)
New Member
Joined: 6 months ago

Okay... I have deleted the Caches and minified files from Siteground as well as the SG Optimizer plugin.

I have disabled the live updates. The problem still remains.

Also, please note that we have previously done the above as well as we have deleted the plugin, but the wpdiscuz line still remains.

81.164.119.223 www.rjworld.org - [31/Aug/2020:10:05:29 +0000] "GET /wp-json/wpdiscuz/v1/update?postId=502&lastId=0&visibleCommentIds= HTTP/2.0" 403 98 "https://www.rjworld.org/restorative-cities-perspectives-on-current-models-at-rj-world/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36" | TLSv1.3 | 0.372 0.389 0.390 BYPASS W NC:200000 UP:1

50.67.184.159 www.rjworld.org - [31/Aug/2020:10:05:28 +0000] "GET /wp-json/wpdiscuz/v1/update?postId=4587&lastId=188&visibleCommentIds=106%2C188%2C HTTP/2.0" 403 98 "https://www.rjworld.org/speaker/prof-jennifer-llewellyn/" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.125 Safari/537.36" | TLSv1.3 | 0.370 0.388 0.388 BYPASS W NC:200000 UP:1

91.157.214.110 www.rjworld.org - [31/Aug/2020:10:05:27 +0000] "GET /wp-json/wpdiscuz/v1/update?postId=4625&lastId=122&visibleCommentIds=51%2C52%2C56%2C71%2C76%2C80%2C122%2C HTTP/2.0" 403 98 "https://www.rjworld.org/speaker/tim-chapman/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.2 Safari/605.1.15" | TLSv1.2 | 0.406 0.416 0.416 BYPASS W NC:200000 UP:1
Reply
deewinc
Posts: 32
(@deewinc)
Eminent Member
Joined: 2 months ago

I can see this issue on several posts. All the time WPDiscuz support is shifting blame to your host yet the host is blaming the plugin for the spike in CPU usage. 

 

Did you finally address the issue? 

Reply
2 Replies
Asti
 Asti
Support
(@asti)
Joined: 3 years ago

Support member
Posts: 2144

@deewinc,

If you deactivate the wpDiscuz plugin there is no way for those requests to be sent from wpDiscuz side. It's a cache for sure. 

Reply
deewinc
(@deewinc)
Joined: 2 months ago

Eminent Member
Posts: 32

@asti~ thanks for that...will be on the watchout in the future. But what could be causing that issue to arise? I kept everything simple based on the optimization features of this plugin. I do hope that it will work best at all times. 

Also, my server is pretty powerful too. 

Reply
Share: