Can't remove wordpr...
 
Share:
Notifications
Clear all

[Solved] Can't remove wordpress black text color, and badges

7 Posts
2 Users
1 Likes
536 Views
Posts: 5
Topic starter
(@branjoseph)
Active Member
Joined: 2 years ago

Hello

When I added wpDiscuz everything looked great. Comments from admin/author had the wpDiscuz green "Author" badge, and didn't have any small social media logo on itΒ 

In social media settings I added Wordpress as a login. I ended up not liking that, so I removed the Wordpress login option.

Ever since then any author comments have a BLACK "author" badge, and username in black (impossible to see on dark background, even in dark mode) and it still has the little "W" logo as a sub-icon badge

I have tried clearing the cache, as well as clearing the entire cache for my site. I tried changing the colors in the badges settings, and it seems the black Wordpress overrides it. I also tried completely uninstalling plugin and reinstalling, and it still remains. I really just want it to go back to normal. Here is a screenshot and a link.

(Mildly NSFW) Throwback: Britney Spears by Steven Klein, 2001 | Male Models | Celebrities | Pop Culture | Poison Paradise

CleanShot 2022 04 11 at 17.47.56@2x
6 Replies
Asti
Posts: 6975
 Asti
Support
(@asti)
Illustrious Member
Joined: 6 years ago

Hi,

You should disable the "Display Social Network Icon on User Avatars" option. It's located in the Dashboard > wpDiscuz > Settings > Social Login and Share admin page.Β 

Posts: 5
Topic starter
(@branjoseph)
Active Member
Joined: 2 years ago

Hi, thanks for the response! I really appreciate it

Unfortunately this does not solve the issue at hand.
If I disable said setting, it globally disables ALL social network icons on avatars, as well as colors (Twitter, Disqus, etc). I only want it to remove the black/wordpress font color and icon

I know it should be possible, because when I first installed and setup everything, Admin/Author comments were not black text and didn't have the W icon. It wasn't until I enabled "Wordpress" social login that it started, and now I cannot get rid of it unless I turn it off globally

Any more help would be appreciated! Thanks again

1 Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6975

@branjoseph,

Then you can use the CSS code:Β 

#wpdcom.wpd-dark .wpd-comment .wpd-avatar i.fab.fa-wordpress {
     display: none !important;
}

Put the code in the Top Admin Bar > Customize > Additional CSS > "Additional CSS" textarea, save it, delete all caches and check again.

Posts: 5
Topic starter
(@branjoseph)
Active Member
Joined: 2 years ago

That worked to get rid of the W icon, thank you so much!Β 
Is there a way to remove the black badge color for "author" and the text?
This is what it used to look like before I enabled and disabled Wordpress social login and this is what I would like it to look like again:

Screen Shot 2022 04 14 at 1.48.08 AM
1 Reply
Asti
 Asti
Support
(@asti)
Joined: 6 years ago

Illustrious Member
Posts: 6975

@branjoseph,

Please insert this CSS code:

#wpdcom .wpd-blog-post_author .wpd-comment-author, #wpdcom .wpd-blog-post_author .wpd-comment-author a {
      color: #ccf547 !important;
}
#wpdcom .wpd-blog-post_author .wpd-comment-label{
     background-color: #ccf547 !important;
}
Posts: 5
Topic starter
(@branjoseph)
Active Member
Joined: 2 years ago

That will work! that did it! Not sure what happened and why it needed a workaround but it works for me!

Thank you for your helpΒ 

Share: